high resolution console on intel & maverick

Asked by Bogdan Butnaru on 2010-09-03

Hello there!

I’ve been trying for years to get a very simple, native-resolution console on Ubuntu, with only a little success. The machine is a file server with an Intel D945GCLF motherboard. It has what Intel calls a “Intel® Graphics Media Accelerator 950”. This is connected to my HP LP2475w monitor, which has a native resolution of 1920x1200 (wide-screen). It runs on the

There’s no X11 installed. I don’t want any graphics, boot splash, or any of that fancy stuff. I just want the simplest possible, text-mode all the way boot process. I’d like it to get into the native resolution as soon as possible during boot: ideally, right after grub starts the kernel; I’ve disabled the grub menu so I don’t care much how it looks, as long as I can access it in case of emergency.

I’ve tried all kinds of things on the net, but without much success. Right now, the boot process starts with a very ugly resolution (not sure, but it looks like the age-old DOS text mode). The screen goes blank at some point. Rather late in the boot process, when everything already scrolled out of the screen, it somehow turns to the native resolution, just a bit before the login prompt appears. I’m not quite sure why that is; some of the things I’ve tried during the last year or so must have worked. I’d like to get it to that state earlier, but I’m reluctant of trying things blindly for fear of making it worse.

The only thing that seemed promising was the uvesafb solution I’ve seen described. Unfortunately, the graphics adapter doesn’t support my resolution, so I can’t use that. Please help!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-03
Last reply:
2010-09-03

Can you help with this problem?

Provide an answer of your own, or ask Bogdan Butnaru for more information if necessary.

To post a message you must log in.