updates can not install 12.04 X-ORG Xserver QXL driver

Asked by ken brockman on 2013-02-10

I have a Security update for the X-Org Xserver QXL display driver, that will not install. I can not check the install box next to driver and the install update is ghosted. All other updates load no problem. Anyone know how i can clear it and try again? I've rebooted that did not help. I have had ongoing problems with the graphics in 12.04 ever since i had installed a new video card and hopefully this may help. My windows all close then reopen after a few seconds every 30 mins or less. I had posted a question, or two about it months ago but never got any help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2013-02-11
Last query:
2013-02-11
Last reply:
2013-02-11

what is the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

ken brockman (krush1954) said : #2

 *-display
       description: VGA compatible controller
       product: Caicos [Radeon HD 6450]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:43 memory:c0000000-cfffffff memory:fea20000-fea3ffff ioport:e000(size=256) memory:fea00000-fea1ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise
Linux bob-A880GZ 3.5.0-18-generic #29-Ubuntu SMP Wed Oct 24 19:51:55 UTC 2012 i686 athlon i386 GNU/Linux

i recommend you install the proprietary video driver. you are using the open driver

ken brockman (krush1954) said : #4

NO,,I had tried that over and over and over again..With the Proprietary drivers it is even worse. The display is screwed up and flickers, that is when it runs at all. Mostly after a day or so or when i reboot, the screen is totally black with just a small area the length of the display at the the very top that is maybe 5 pixels deep. I can see just the tip of my pointer on the very top of the screen.. Been there, done that. Over half a dozen times!!!

What else you got?

I had loved Ubuntu 11.04, it ran like a tank, 12.04 by contrast has been trouble from day one.. Have had one problem after another.. nightmarish... Sorry If I sound ungrateful but living with 12.04 for these many months has made me a bit sour..

I was thinking of upgrading to 12.10, but after reading all of the horror stories I am reluctant.

ken brockman (krush1954) said : #5

a

ken brockman (krush1954) said : #6

am I right to thing that this indicates that my video card has 256 meg ram?:

 resources: irq:43 memory:c0000000-cfffffff memory:fea20000-fea3ffff ioport:e000(size=256) memory:fea00000-fea1ffff

I ask because the card in question has 2 gig ram..

Try Unity2Don't session. May help

Best N1ck 7h0m4d4k15 (nicktux) said : #8

Do not upgrade to Ubuntu 12.10

You can use a lighter desktop environment if you want.. such as XFCE or LXDE .. you can try to install Xubuntu or Lubuntu or keep 12.04 and see how Unity 2D performance is..

As for the problem with xserver-xorg-video-qxl , I think you can ignore it.. and I don't know how you installed this package, because is not installed by default.

See the description of the package in apt-cache..

apt-cache show xserver-xorg-video-qxl

I think you can safely remove it..

sudo apt-get purge xserver-xorg-video-qxl

and the update problem will also be vanished.

Thanks

ken brockman (krush1954) said : #9

Well thanks NikTh, I did check and have no clue as to how that bit ( xserver-xorg) had been installed. I have purged it from my system and with it went the update issue. As far as the rest, I really love ubuntu with compiz and cario-dock. I could get rid of them and(or) run a lighter install, but what's the point. These are what makes the OS so enjoyable for me..If I ditched them I lose 50% of the joy of running Ubuntu in the 1st place..I might just as well go back to mint

just tonight upgraded cairo-dock :

Installed version: 3.1.99.beta0.1~20130207~bzr1383-0ubuntu1~ppa0~precise
Available version: 3.1.99.rc1.1~20130210~bzr1387-0ubuntu1~ppa0~precise

I had noticed i had gone from a beta to the rc version. I was hoping this was the answer i had been seeking for months, but alas within 30 minutes the same problems arose..sigh..
thanks once again for your help

ken brockman (krush1954) said : #10

Thanks NikTh, that solved my question.