Empty desktop

Asked by Juha Vuorinen

After updating Ubuntu 12.10's software, the desktop seems to be empty. In the log in screen i can see the horizontal panel but when i log in, it disappears. Before these software updates i had a problem with the panels but i managed to fix it with help.

Now there's nothing..

Question information

English Edit question
Ubuntu xserver-xorg-video-ati Edit question
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

What video chip do you use?
Does the system have a make and model?

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :

Try to boot from an older kernel.. do you have a grub menu ? Go to "advanced settings for Ubuntu" and boot from an older kernel.

Probably the kernel's upgrade broke the driver.

If it works from the older kernel , then do again the procedure at this question

an reboot from the newer kernel and see if fixed.


Revision history for this message
Juha Vuorinen (juhap-vuorinen) said :

Doesn't have make nor model since I've built it myself. The motherboard is Asus sabertooth 990FX and the video card is ATI radeon HD5870 Eyefinity 6.

Revision history for this message
Juha Vuorinen (juhap-vuorinen) said :

NikTh i tried it your way.. With the older kernel everything looks fine but it doesn't do anything with the display drivers because they're already there. Did everything again anyway, and when i went back to the new, it was the same. Also when i plugged in a usb-stick, the folder opened, and when i moved it, it happened in slow motion. Seems like the problem is with the video card but it's really almost impossible to manage anything because i can't see either of the panels. So it's rather hard to access anything.


Revision history for this message
Best N1ck 7h0m4d4k15 (nicktux) said :

Maybe the problem is with the newer kernel , it is OK , you can boot from the older , until a newer version of the kernel comes out , and then you can test it.

If with the older kernel everything seems ok , then probably something is going wrong with the newer kernel. Usually a re-installation of the driver fix things , but is not for sure.


Revision history for this message
Juha Vuorinen (juhap-vuorinen) said :

Thanks NikTh, that solved my question.