Screen adjusting: Desktop too big for screen.

Asked by Juha Vuorinen on 2013-01-15

Greetings.

First of all i apologize if my english ain't exactly the best. :)
I'm from Finland but i wanted to post in english because i think i'll have an answer a lot faster. So.. The problem is that i cant see the horizontal panel almost at all. Cursor moves in there though so i can do things blind but its really annoying. Same thing with the vertical panel from which i can see only half, if even that.
I've tried adjusting resolution and refresh rate but it doesn't help. I know about a semi-lot of shit about computers but i've always used Windows as an OS mainly bacause i play like 99% of my games on a computer so i know NOTHING about Ubuntu. So.. Just a couple of days ago i installed Ubuntu alongside of my Windows 7 because i've heard so much good about it. Everything went smoothly except this one little thing. In the displays menu i noticed that it misinterprets my monitor as 32". Actually its a 50" 720p HD Ready plasma TV. Don't know if that's a problem.. I have an ATI Radeon HD 5870 Eyefinity 6 graphics card and in Windows everything works normally.
I've been trying to read some e-books about Ubuntu but i've found nothing related to my problem. Really useful information for a beginner though. Isn't there any "manual scaling" option in Ubuntu, so i could shrink the screen down a little?

Thanks for the the help in advance. :)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2013-01-16
Last query:
2013-01-16
Last reply:
2013-01-16
Juha Vuorinen (juhap-vuorinen) said : #1

I knew i'd forget something.. I'ts Ubuntu 12.10

What is the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

Juha Vuorinen (juhap-vuorinen) said : #3

That's another problem.. sudo lshw -C display; lsb_release -a; uname -a Where i can see this?

N1ck 7h0m4d4k15 (nicktux) said : #4

Open a terminal (CTRL+ALT+T) and copy-paste the commands from here to the terminal

Post back here the results.

Thanks

Juha Vuorinen (juhap-vuorinen) said : #5

Okay. Thank you for the answer. I'll try it tomorrow and write back. :)

Juha Vuorinen (juhap-vuorinen) said : #6

zeipii@ubuntu:~$ sudo lshw -C display; lsb_release -a; uname -a
[sudo] password for zeipii:
  *-display
       description: VGA compatible controller
       product: Cypress XT [Radeon HD 5870]
       vendor: Advanced Micro Devices [AMD] nee ATI
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:87 memory:c0000000-cfffffff memory:fe620000-fe63ffff ioport:c000(size=256) memory:fe600000-fe61ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux ubuntu 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
zeipii@ubuntu:~$

Juha Vuorinen (juhap-vuorinen) said : #7

Also in computer details, under graphics it says dricer unknown.

Best N1ck 7h0m4d4k15 (nicktux) said : #8

I think that your problem will be solved if you install the fglrx . (AMD/ATI driver).

Now you use the open source - pre-installed - radeon. Good driver but limited capabilities compared to fglrx.

So, open a terminal (CTRL+ALT+T) and apply the commands below , one by one.

sudo apt-get install --reinstall linux-headers-$(uname -r)
sudo apt-get install fglrx fglrx-amdcccle
sudo amdconfig --initial

Then reboot you system. If some of above commands return an error message , please post it here.

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #9

The "driver unknown" behavior is another "problem" and can be solved easily.

sudo apt-get install mesa-utils

after installation finish , check again the "graphics" .

:-)

sudo apt-get install fglrx fglrx-amdcccle
No error but: Warning: No support for locale: en_US.utf8

AND

zeipii@ubuntu:~$ sudo amdconfig --initial
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.original-0
zeipii@ubuntu:~$

Don't know what was supposed to happen there. I'll reboot now and come back.

The "driver unknown" behavior is another "problem" and can be solved easily.

sudo apt-get install mesa-utils

after installation finish , check again the "graphics" .

Didn't need to do that. I did everything else and works like a charm. :)
I have to say that i am stunned by the knowledge in this forum. :D
Now the display card's fan is also quieter than before.

Thanks. Much appreciated. :)

N1ck 7h0m4d4k15 (nicktux) said : #12

Please re-edit the question an mark the answer that solved your problem (for future - help - other with same problem).

Thanks

P.S:
mesa-utils needed when you don't have the fglrx installed (as you were before). Now is not needed , fglrx undertake the actions.

Thanks NikTh, that solved my question.