installing ATI Radeon 3400 on ubuntu 12.10

Asked by moawiya mograbi on 2013-01-02

when I install ATI Radeon 3400 on my computer lenovo ideaPad u550 ( ubuntu 12.10 ) I could never get to the desktop again ... when I login I got nothin ! just the picture of the desktop. please Help !

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-02
Last reply:
2013-01-03
N1ck 7h0m4d4k15 (nicktux) said : #1

Yes , this is because AMD/ATI dropped the support for cards 2xxx-4xxx series for Linux.

So you have to either use the 12.04 LTS release of Ubuntu or to "hack" some things at 12.10

IF you want to use the AMD/ATI drivers on 12.10 (for your card) , follow the commands below. (execute one at time)
Run below commands on terminal (CTRL+ALT+T) or Console Mode (CTRL+ALT+F2)

sudo apt-get purge fglrx*
sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

After the procedure finish , reboot your PC.

sudo reboot

-------------------------------------------------------------------------------------------------------------------------------------------------------------

If is still not working , then you have to move to 12.04 LTS or use the open source driver (radeon)

To use the open source driver (radeon) at Ubuntu 12.10 , execute the commands below

sudo apt-get install ppa-purge
sudo ppa-purge ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri libgl1-mesa-glx libgl1-mesa-dri
sudo dpkg-reconfigure xserver-xorg
sudo reboot

Thank you.

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

The xorg in Quantal hates 2xxx 3xxx and 4xxx ati gpus

I did what u wrote and then I tried to install amd-driver-installer-12.6-legacy-x86.x86_64.run from AMD
and I gets this error :

/usr/share/ati/fglrx-install.log

Check if system has the tools required for installation.
Uninstalling any previously installed drivers.
Unloading drm module...
ERROR: Module drm is in use by i915,drm_kms_helper
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.5.0-21-generic/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-headers-3.5.0-21-generic'
  CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_MEM_AllocLinearAddrInterval’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2152:5: error: implicit declaration of function ‘do_mmap’ [-Werror=implicit-function-declaration]
cc1: some warnings being treated as errors
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-21-generic'
make: *** [kmod_build] Error 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.
[Reboot] Kernel Module : update-initramfs

N1ck 7h0m4d4k15 (nicktux) said : #4

Who told you to install the .run file from AMD site ?

neither @actionparsnip or me ..

Please open the terminal and execute the commands as we told you..

COPY - PASTE from here.. one at time.. the first set of commands on answer #1 or the set of commands on answer #2 (are the same).

Thanks

Can you help with this problem?

Provide an answer of your own, or ask moawiya mograbi for more information if necessary.

To post a message you must log in.