New to linux-No GUI shown after login

Asked by Ross Dobson on 2012-11-18

I'm new to Linux, so if I'm doing something nooby, I'm sorry :D

When I start Ubuntu (12.10) I see the standard login, it shows the bar with the clock and stuff at the top, tells me how I'm not connected to a network (another problem, doesn't like my wireless card). But as soon as I log in, the gui vanishes! I can right click and access the display settings, and subsequently all settings, but I cant see the title of any windows, or the launcher bar thing at the side, or the title bar at the top. I've tried changing my resolution, but to no avail. All I can see is the contents of the settings window.

I have an Intel Pentium M 1.7ghz (Dothan I think?) and my graphics chip is an ATI Mobility Radeon 9000 series. Any other specs you need, just say so :)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
Ross Dobson
Solved:
2012-11-20
Last query:
2012-11-20
Last reply:
2012-11-19

Try the boot option:

radeon.nomodeset=1

Ross Dobson (rossdobson) said : #2

Where do I type/try/enter this?

Ross Dobson (rossdobson) said : #4

This....is all very confusing. Is there a step by step guide, as that just all went straight over my head :(

Sigh....

Hold SHIFT at boot then press E to (e)dit the line, delete the words:

quiet splash

and in the same place add:

radeon.nomodeset=1

Press ENTER to continue the boot.

Ross Dobson (rossdobson) said : #6

Hey I said I was a noob...

This does solve it, but it runs VERY slowly, but I have no more graphical glitches. However, I hit F10 as it said to (enter just moved the line down) but it hasn't remembered my changes, so I have to do it every time I boot. Is there something like a driver or patch I could install?

Its not about being new, you just have to read. Nothing more.

Get fully updated and then reboot

Ross Dobson (rossdobson) said : #8

I tried reading it and got confused.

Get fully updated? I assumed that Wubi always grabbed the most recent version.

Do you mean to update within Ubuntu? As it said I was up to date...

Ross Dobson (rossdobson) said : #9

I'll do some more googling, see if anyone has similar problems...

If you wait til the login screen and press CTRL+ALT+F1 and login there, then run:

sudo apt-get update; sudo apt-get install xfce4

(I assume you have web access), you can then reboot by running:

sudo reboot

And log in to the XFCE session, should give you a usable OS

Ross Dobson (rossdobson) said : #11

Another slight problem:

For some reason, although XP recognises it fine, Ubuntu doesn't like my wi-fi card. If I do what you said above, it says err http://blahblah

Then says reading package lists: and it counts up to 100%
W: failed to fetch (insert long URL here)
(See above)
(See above)
(See above)
(Again)
(And again)

x some index files failed to download. They have been ignored or old ones will be used instead.
Building depend tree:
The following extra packages will be installed:
(Insert metric crap ton of stuff here)
Suggested packages:
(Insert half a metric crap ton of stuff here)
The following new packages will be installed:
(Lists all of the extra packages being installed from above)
0 upgraded, 37 newly installed, 0 to remove and 0 not upgraded.
Nee to get 13.7 MB of archives.
After this, 57.2 mb of additional disk space will be used?
Continue [Y/N]
(Insert
A
Crap
Ton
Of
Stuff
Here
"Err
Could not resolve 'archive.ubuntu.com'
(See Above 5 times or so)
Failed to fetch (stuff)
(See above 20 times or so)
E: unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Something tells me I need to Ubuntu connected to the Internet, but how? :/

Do you have a web connection?

Ross Dobson (rossdobson) said : #13

I haz an idea. I was reading up on the changes to Ubuntu made in 12.10, and part of it was some hefty graphics rediddling. SO, because 8 year old business laptops aren't gonna have the most up to date graphics hardware, I'm gonna reformat the partition and try the LTS instead :) thanks for all your help btw :)