Problem with Ubuntu 12.10 64 bit & Ati Radeon 7870

Asked by Massimiliano Maniscalco on 2012-11-13

I use Ubuntu 12.10 64bit desktop versione on my system with Gnome 3 as a default desktop manager. Everything worked well with Intel integrated graphics HD4000, this is my system configuration:
Asus P8Z77-V Pro/Thunderbolt motherboard
Intel i7 3770k
16 Gb Corsair Vengeance

Now I just installed a graphic card Ati Radeon 7870 and I have several issues:
1) if I try to use Ati Catalyst driver nothing work anymore, Gnome 3 doesn't start, it always start as Gnome Classic, Unity doesn't work, no launch bar on the left, no menu bar, I just see the desktop.
2) if I use open source driver performance are very poor, Wine doesn't work anymore.

Should I re-install the system to make it work well?

By the way, should I connect my monitor on the HDMI of the motherboard or on the HDMI of the graphic card? I'm using the HDMI of the graphic card now.

Thank you for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
Massimiliano Maniscalco
Solved:
2012-11-15
Last query:
2012-11-15
Last reply:
2012-11-14

I ever received an alert that Compiz crashed and then it said that I have a 3D accelerated card but X.org is using software rendering instead of hardware...

massi@FreePower:~$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI PITCAIRN [Radeon HD 7800]
massi@FreePower:~$ lshw -c display | grep driver
WARNING: you should run this program as super-user.
       configuration: driver=radeon latency=0
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
massi@FreePower:~$ sudo lshw -c display | grep driver
[sudo] password for massi:
       configuration: driver=radeon latency=0
massi@FreePower:~$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
    GL_NV_conditional_render, GL_AMD_draw_buffers_blend,
massi@FreePower:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
OpenGL version string: 2.1 Mesa 9.0

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: no
massi@FreePower:~$

What is the output of:

sudo lshw -C display; lsb_release -a; uname -a; sudo dmidecode -t 1

Thanks

*-display
       description: VGA compatible controller
       product: PITCAIRN [Radeon HD 7800]
       vendor: Advanced Micro Devices [AMD] nee ATI
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:54 memory:e0000000-efffffff memory:f7e00000-f7e3ffff ioport:e000(size=256) memory:f7e40000-f7e5ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux FreePower 3.5.0-18-generic #29-Ubuntu SMP Fri Oct 19 10:26:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
# dmidecode 2.11
# SMBIOS entry point at 0x000f04c0
SMBIOS 2.7 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
 Manufacturer: System manufacturer
 Product Name: System Product Name
 Version: System Version
 Serial Number: System Serial Number
 UUID: 5363EAE0-D7DA-11DD-B070-3085A93A97D7
 Wake-up Type: Power Switch
 SKU Number: SKU
 Family: To be filled by O.E.M.

Seems that problem is about xserver-xorg-intel package, I found a guide on this post

http://ubuntuforums.org/showpost.php?p=12324761&postcount=503

This solved my problem, now I can use my Radeon HD 7870!