Videos got slower for radeon 7000

Asked by hpkeck on 2012-11-03

I recenty started to migrate from Lucid (10.04) to Precise (12.04). Unfortunately, I have noticed that the video rendering performance has decreased with Precise. Videos with a resolution of about 720x576 that are played smoothly on Lucid are either flickering or shortly hanging in-between while played on Precise (the standard video player tends more to flickering, in vlc I get hangs).
I should mention that I have a quite old graphics card, it is identified by the X server as
    Chipset: "ATI Radeon VE/7000 QY (AGP/PCI)" (ChipID = 0x5159)
At first I tried booting with "radeon.modeset=1" or setting RenderAccel "off" in the xorg.conf, but this didn't help. Then I thought that this behaviour might be caused by problems in the xserver-xorg-video-ati driver, so I tried compiling an old version (6.13.1), that matches somehow the one used in Lucid. But this didn't help either, the performance is as poor as before.
I would like to narrow down the problem, but I am currently unsure how to proceed. Are there any tools that can help in debugging? I have installed Lucid and Precise on different partitions, so I can easily compare between them. Should I try a different kernel? Any other ideas how to proceed?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-04
Last reply:
2013-02-10

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

hpkeck (navaj072-info) said : #2

The output is:
  *-display
       description: VGA compatible controller
       product: RV100 QY [Radeon 7000/VE]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: c
       bus info: pci@0000:00:0c.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=64 mingnt=8
       resources: irq:17 memory:f0000000-f7ffffff ioport:a000(size=256) memory:fbd00000-fbd0ffff memory:fbc00000-fbc1ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux faramir 3.2.0-32-generic-pae #51-Ubuntu SMP Wed Sep 26 21:54:23 UTC 2012 i686 athlon i386 GNU/Linux

BTW, I am not using the unity desktop, because it feels a bit slow. Currently I am using the "GNOME classic (no effects)" kind of session.

Interestingly, the output of lshw on Lucid is slightly different:
  *-display
       description: VGA compatible controller
       product: Radeon RV100 QY [Radeon 7000/VE]
       vendor: ATI Technologies Inc
       physical id: c
       bus info: pci@0000:00:0c.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list rom
       configuration: driver=radeon latency=64 mingnt=8
       resources: irq:17 memory:f0000000-f7ffffff(prefetchable) ioport:a000(size=256) memory:fbd00000-fbd0ffff memory:fbc00000-fbc1ffff(prefetchable)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.4 LTS
Release: 10.04
Codename: lucid
Linux faramir 2.6.32-44-generic #98-Ubuntu SMP Mon Sep 24 17:32:45 UTC 2012 i686 GNU/Linux

hpkeck (navaj072-info) said : #3

I searched the internet and found a boot option that I didn't know so far: nomodeset. When I boot with this option the video rendering improves. The standard video player (totem) now can play MP4 smoothly (but not MPEG2), VLC plays MPEG2 smoothly (but not MP4). But as all kinds of videos are played smoothly by avplay, I think the format-dependant problems are individual player problems. I will analyse them later.
Should I report a bug, because I need nomodeset?

Unity isn't a desktop, it is a she'll. Gnome is still the desktop and Compiz is the Window Manager.

Can you help with this problem?

Provide an answer of your own, or ask hpkeck for more information if necessary.

To post a message you must log in.