Radeon HD 4870 not supported in 12.10

Asked by Paddy Thomas on 2012-11-01

Unable to get full HD with my Radeon HD 4870. Seems to be due to lack of appropriate driver. Any intention of fixing this soon?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2012-11-03
Last query:
2012-11-03
Last reply:
2012-11-03
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,

No , not soon. AMD(ati) dropped the support for Linux in closed source driver(fglrx) for 2xxx-4xxx graphic cards.

See here : http://phoronix.com/forums/showthread.php?70500-AMD-To-Drop-Radeon-HD-2000-3000-4000-Catalyst-Support

So you have 2 options for now.

Either to work with the open source (radeon) driver or install the legacy driver but you have to drop the version of Xorg to 1.12.

Ubuntu 12.10 uses the 1.13 version of Xorg where is incompatible with the legacy Driver.

An external ppa can do this "job" for you automatically.

Read here:
http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html

Thanks

Paddy Thomas (paddy-pdpthomas) said : #2

Many thanks. Have dropped to Xorg 1.12 and installed legacy driver. HD
has returned!

Will update manager try to upgrade Xorg?

Best wishes

Patrick Thomas

On 01/11/12 18:55, NikTh wrote:
> Your question #213017 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/213017
>
> Status: Open => Answered
>
> NikTh proposed the following answer:
> Hi ,
>
> No , not soon. AMD(ati) dropped the support for Linux in closed source
> driver(fglrx) for 2xxx-4xxx graphic cards.
>
> See here : http://phoronix.com/forums/showthread.php?70500-AMD-To-Drop-
> Radeon-HD-2000-3000-4000-Catalyst-Support
>
> So you have 2 options for now.
>
> Either to work with the open source (radeon) driver or install the
> legacy driver but you have to drop the version of Xorg to 1.12.
>
> Ubuntu 12.10 uses the 1.13 version of Xorg where is incompatible with
> the legacy Driver.
>
> An external ppa can do this "job" for you automatically.
>
> Read here:
> http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html
>
> Thanks
>

Best N1ck 7h0m4d4k15 (nicktux) said : #3

On 11/03/2012 02:45 PM, Paddy Thomas wrote:
> Many thanks. Have dropped to Xorg 1.12 and installed legacy driver. HD
> has returned!
>
> Will update manager try to upgrade Xorg?
>
> Best wishes
>
> Patrick Thomas
>
>
As you have the PPA enabled you are OK.

You can mark the question as solved.

Thanks

Paddy Thomas (paddy-pdpthomas) said : #4

Thanks NikTh, that solved my question.