Video playing slow (full screen) - Ubuntu 12.04

Asked by Danilo Mendes Akiau on 2012-10-22

Hello, first I wanted to say that I am new in using Linux and so I may not understand some terms.
What happens is this, I have several .avi videos in my folder
I have already installed all the necessary codecs and the driver of my video card is installed and working perfectly well (ATI Mobility Radeon HD 4250)
Well, the problem is that whenever I run a video in full screen (fullscreen) by VLC or other media players, video wheel locking up, as if skipping frames, making it unpleasant and impossible to watch anything
I tested the same video in full screen in Windows 8 and it worked perfectly fine (I have Dual Boot with Ubuntu and Windows), but I wonder what happens in Linux to do the video hangs ...
Initially I thought it was the video card misconfigured but did several tests and all is right.
Detail, when I try to watch videos in full screen on youtube in HD quality 1080p the videos work perfectly well, without crashing.

Note: I'm using Ubuntu 12.04

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
Danilo Mendes Akiau
Solved:
2012-10-25
Last query:
2012-10-25
Last reply:
2012-10-23

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark'

Thanks

Thanks, but the problem persist
It isnt a flash problem i think, because in youtube I can play HD videos in 1080p without lagging
Just in the VLC player the video playing with lag (in fullscreen mode) and I don't no why :(
My PC have a good processor (AMD Phenom(tm) II N930 Quad-Core Processor × 4), and 6gb of RAM, with a decent video card (ATI Mobility Radeon HD 4250)
The problem have no sense

It doesn't change anything, so the problem will persist. I asked for the output which you haven't given yet.....

It's strange because when I use resolution 1920x1080 (1080p) on my Monitor (it' defaut) the video lagging but when I force the screen to a lower resolution like 1366x768 and playing a video, the video don't lag...

Please see #1

Please copy the output and paste here as an update.

Sorry, the output is:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux dan-HP-Pavilion-dv6-Notebook-PC 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ii flashplugin-installer 11.2.202.243ubuntu0.12.04.1 Adobe Flash Player plugin installer

Try:

sudo apt-get --purge remove flashplugin-installer

Enable the partner repo and install the adobe-flashplugin package

Ok, I can remove flashplugin but how I enable the partner repo and reinstall the adobe-flashplugin package? What is the command in terminal to do it?

You can use software centre to do it all

I do all of this and the problem persist :(
Just in the players (fullscreen mode), in the Youtube 1080p, the movie playing without lags, I don t understand :(

Good News!
I solved the problem :)

Is just configure video output in VLC to X11 and no more lags in fullscreen :D