FGLRX just wont work correctly! Stops compiz and unity

Asked by Christian Macias on 2012-10-12

I have and amd Radeon HD4000 series graphics card and I cannot get it to work with 12.10. Worked perfectly with 12.04. When i run fglrxinfo once i have it installed it returns.

X Error of failed request: BadRequest (invalid request code or no such operation)
  Major opcode of failed request: 153 (GLX)
  Minor opcode of failed request: 19 (X_GLXQueryServerString)
  Serial number of failed request: 12
  Current serial number in output stream: 12

I have tried the patch for kernel 3.4 and 3.5 but still doesnt work. It runs ok (not great like before) when i uninstall all fglrx drivers.

PS my laptop does the exact same thing. It use the hybrid system but has the card HD radeon 6400m/7400m.
I dont know what else to do that can make my computer ran as it was supposed to.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-12
Last reply:
2012-10-12

I suggest you report a bug

Can you help with this problem?

Provide an answer of your own, or ask Christian Macias for more information if necessary.

To post a message you must log in.