Radeon Video card (HD6550D)

Asked by John Davey on 2012-10-10

Hi

I am using Ubuntu 12.04 LTS on a new motherboard (Asus F1A55-M) with an AMD A8 Quad core CPU (APU) with on-board video (Radeon HD 6550D). I am running dual screens - a 1440x900 AOC 19" wide and a 1024x768 Phillips 15". I am using Unity.

Firstly the small monitor (while showing information on it when booting) is never up and running once I have logged in - I have to return to the display settings each time to get it to run.

However worse than this are these problems:

1. Sometimes the GUI appears on the wide screen with the mouse frozen and a reboot is required to get the mouse to work.
2. Sometimes there is no login screen after booting even though both have been active at times during the boot process. There is a purple colour in the background but this reverts to no signal. Nothing produces a login screen or a command prompt so I have to hit the power button and try again. Recently this seems to have got worse and happens at most startups.
3. The system will go to sleep (in due course as it should) but is often very difficult to rouse again. I can usually get it going after at least 30s of key pushing.

I am using the supplied drivers as standard. I have read about the proprietory drivers but there seems to be problems.

Any suggestions greatfully received.

John Davey

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
John Davey
Solved:
2012-10-25
Last query:
2012-10-25
Last reply:
2012-10-10

Have you installed the proprietary video driver?

John Davey (john-davey) said : #2

As stated I am using the supplied drivers as standard. I have read about the proprietory drivers but there seems to be problems.

I suggest you enable the proprietary video driver and it should improve

John Davey (john-davey) said : #4

OK - will try but probably not tonight. I have seen somewhere that it is best not to use the version with the post release options - is that true?

John Davey (john-davey) said : #5

The reason that I am a little reluctant to proceed is threads like this one:
http://ubuntuforums.org/showthread.php?t=1966649

Tried the boot option:

nomodeset

John Davey (john-davey) said : #7

OK - tried nomodeset - this came up with both screens going when logged in but with the wrong resolutions and mirrored. Settings to change the resolution to the correct ones were not present. Could not change out of mirrored screens either.

John Davey (john-davey) said : #8

So I presume the next step would be to create a Xorg.conf file?

John Davey (john-davey) said : #9

I have been very reluctant to change things where time would be needed to get my system back to normal since I use it 2-3 hours each night getting material ready for teaching the next day (this includes the weekends even though I am not teaching then).

I have a plan - next weekend is a long weekend here in NZ. So I will give it a go - it seems from my investigation the method least likely to cause strife is to add in from the "Addiitonal Drivers: window "ATI/AMD proprietary graphics driver" NOT the post release up-date one since it does not seem to work for some people.

I will post back when I have tried this.

John Davey (john-davey) said : #10

Got to the stage where it was taking 2-3 reboots to get my GUI up and running so "bit the bullet" and installed the "ATI/AMD proprietary FGLRX graphics driver" without the post-release updates since this seems to have given some people issues on 12.04.

I am pleased to report that all seems well (and I suppose I have to say "why did I not do this sooner!!).

Thanks - all solved I hope (not thoroughly tested at this stage).