Gnome 3 gets blurry after kernel update

Asked by Kristoffer on 2012-10-03

After the last kernel update gnome has been having problems.

What happens:
I start the computer, log in without any problems, and gnome shell shows as normal. After a minute or so something happens to the gnome shell so that I cannot even read the clock. Everything seems to work as expected, but it is unreadable and mostly just black.

Other notes:
If I log out of my account I get the loginscreen again, which looks normal. Every other applications like the browser, email client and everything really works just fine.

Tried thus far:
I logged in using Unity-shell and tried to apt-get remove gnome-shell && apt-get install gnome-shell. No change.

Details:
GNOME Shell 3.4.1
Kernel (uname -r): 3.2.0-31-generic

Screenshot of symtom: http://oi50.tinypic.com/33neoty.jpg

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
Kristoffer
Solved:
2012-10-03
Last query:
2012-10-03
Last reply:
2012-10-03

What is the output of;

sudo lshw -C display; lsb_release -a; uname -a

Thanks

Thanks for you interest.

Here you go:

kristoffer@skynet:~$ sudo lshw -C display; lsb_release -a; uname -a
  *-display
       description: VGA compatible controller
       product: Juniper [Radeon HD 5700 Series]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=fglrx_pci latency=0
       resources: irq:53 memory:d0000000-dfffffff memory:fdfc0000-fdfdffff ioport:ae00(size=256) memory:fdf00000-fdf1ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux skynet 3.2.0-31-generic #50-Ubuntu SMP Fri Sep 7 16:16:45 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Have you tried:

sudo apt-get --reinstall install dkms

Reboot to test

I just tried it, but sadly no change.

If you remove the driver then reinstall it, does it help? If not then I suggest you report a bug

Thanks for all your help Andrew (guessing that is your name).
I was able to purge the old installation and after putting in another GPU so that I could boot and install the proprietary driver. I'm now back in my system and it hasn't crashed yet!

Thanks! :D