Graphics card not detected with 3.2.0-32 kernel update

Asked by penguin on 2012-09-29

I did the update thing this morning. There was a new kernel in the mix, namely 3.2.0-32. After the update, the graphics card wasn't detected, even though it's detected with the 3.2.0-31 kernel. I get a little menu asking if I want to run in low graphics mode for the session, configure the graphics and a couple of other things. No matter what I select, nothing happens. I have a Samsung laptop with AMD A8-3530MX APU with Radeon HD Graphics x 4 VESA: SUMO.

Any suggestions?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
penguin
Solved:
2012-09-30
Last query:
2012-09-30
Last reply:
2012-09-29
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,

try to boot from the older kernel 3.2.0-31 and see if your card works there.

If you don't have a grub menu during boot , then hold down [SHIFT] key until grub menu show up , and choose "previous linux versions".

If your card works fine there , then open a terminal [Ctrl]+[Alt]+t and provide some info .
The results of bellow commands

1) lspci -nnk | grep -iA2 vga

2) cat /etc/modules

3) ls /etc/modprobe.d/

4) ls /etc/X11/

Thanks

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

penguin (penguin) said : #3

NikTh:

Here's what I get using the commands you suggest, using the 3.2.0-31 kernel that worksk just fine from the boot menu:

lspci -nnk | grep -iA2 vga
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI BeaverCreek [Mobility Radeon HD 6620G] [1002:9641]
 Subsystem: Samsung Electronics Co Ltd Device [144d:c609]
 Kernel driver in use: fglrx_pci
--
02:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Seymour [Radeon HD 6400M Series] [1002:6760]
 Subsystem: Samsung Electronics Co Ltd Device [144d:c609]
 Kernel driver in use: fglrx_pci

cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
rtc

ls /etc/modprobe.d/
alsa-base.conf blacklist-firewire.conf blacklist-rare-network.conf
blacklist-ath_pci.conf blacklist-framebuffer.conf blacklist-watchdog.conf
blacklist.conf blacklist-modem.conf vmwgfx-fbdev.conf
blacklist-fglrx.conf blacklist-oss.conf

ls /etc/X11/
app-defaults xkb Xreset.d
cursors xorg.conf-backup-120929032457 Xresources
default-display-manager xorg.conf.failsafe Xsession
fonts xorg.conf.fglrx-0 Xsession.d
rgb.txt xorg.conf.original-0 Xsession.options
X xorg.conf.original-1 Xwrapper.config
xinit Xreset

Things work like a charm with it.

penguin (penguin) said : #4

actionparsnip:

Your command nets this:

  *-display
       description: VGA compatible controller
       product: BeaverCreek [Mobility Radeon HD 6620G]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 1
       bus info: pci@0000:00:01.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=fglrx_pci latency=0
       resources: irq:43 memory:a0000000-afffffff ioport:f000(size=256) memory:feb00000-feb3ffff
  *-display
       description: VGA compatible controller
       product: Seymour [Radeon HD 6400M Series]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=fglrx_pci latency=0
       resources: irq:44 memory:b0000000-bfffffff memory:fea20000-fea3ffff ioport:e000(size=256) memory:fea00000-fea1ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux samsung 3.2.0-31-generic #50-Ubuntu SMP Fri Sep 7 16:16:45 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

N1ck 7h0m4d4k15 (nicktux) said : #5

How did you install the driver for ATI ?

From additional drivers ? or from the site ?

You can try to install again the driver , with the newer kernel .

Boot from the newer kernel and open a terminal , then IF you installed ATI driver through additional drivers , do this

sudo apt-get install --reinstall fglrx fglrx-amdcccle

wait for the installation to finish and then give this command

sudo aticonfig --initial

IF you installed ati driver from ati's site , (with .run script) then post back here cuz is another procedure you must follow.

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #6

As a workaround you can booting from the older kernel . The differences are to little that only the kernel developers team can identify.

Hopefully with an update , your problem will be solved.

Also you can fill a bug if you want.

penguin (penguin) said : #7

NikTh:

I did nothing special to install the driver. As far as I can tell, it was installed when I initially installed 12.04. I could try to reinstall the driver via apt-get to see if that might help. If that doesn't help, I suppose I could try to install it via ATI's site to see if that does anything.

penguin (penguin) said : #8

After whacking away at it for awhile, and not getting the desired results, I solved the problem by removing the "offending" 3.2.0-32 kernel, since it wasn't working properly. I'll stick with 3.2.0-31 for now, since it actually DOES work without issue.

Thanks for your help.