Dual Display, ubuntu 12.04, 1617 gateway laptop, samsung 40 tv, display runs over the edges

Asked by jobra on 2012-08-23

Dual Display: ubuntu 12.04, 1617 gateway laptop, when screen resolution is 1920 on samsung 40 tv, DISPLAY runs over the edges and cover top panel and side launcher. how can i adjust so that everyhing will be dispalyed with in the border of the tv screen. on monitors you can use the buttons to adjust the surface area of the screen. The TV has no option. Everything works fine. under 168ox resoulution i dont't have this problem. If you can help i greatly appreciated:

TV IS SAMSUNG 6300 LED 40'

 *-display
       description: VGA compatible controller
       product: RS690M [Radeon X1200 Series]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 5
       bus info: pci@0000:01:05.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=64
       resources: irq:18 memory:b0000000-bfffffff memory:cfdf0000-cfdfffff ioport:9000(size=256) memory:cfe00000-cfefffff

MORE INFO HERE:

01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS690M [Radeon X1200 Series]
drm_kms_helper 45466 1 radeon
drm 197692 5 radeon,ttm,drm_kms_helper
/dev/fb0
/dev/video0
/dev/dri/card0
/dev/dri/controlD64
BOOT_IMAGE=/boot/vmlinuz-3.2.0-29-generic-pae root=UUID=52ff5aa7-5d30-4f7a-8cad-60af63ffafa3 ro quiet splash radeon.audio=1 vt.handoff=7
/etc/modprobe.d/
/etc/modprobe.d/blacklist-modem.conf
/etc/modprobe.d/blacklist-framebuffer.conf
/etc/modprobe.d/alsa-base.conf
/etc/modprobe.d/blacklist-watchdog.conf
/etc/modprobe.d/blacklist-firewire.conf
/etc/modprobe.d/blacklist-ath_pci.conf
/etc/modprobe.d/blacklist.conf
/etc/modprobe.d/blacklist-rare-network.conf
/etc/modprobe.d/blacklist-oss.conf
/etc/modprobe.d/vmwgfx-fbdev.conf
cat: /etc/modprobe.d/*kms*: No such file or directory
ls: cannot access /etc/X11/xorg.conf: No such file or directory
The program 'glxinfo' is currently not installed. You can install it by typing:
sudo apt-get install mesa-utils
[ 20.189] (II) LoadModule: "extmod"
[ 20.286] (II) LoadModule: "dbe"
[ 20.315] (II) LoadModule: "glx"
[ 20.353] (II) LoadModule: "record"
[ 20.382] (II) LoadModule: "dri"
[ 20.383] (II) LoadModule: "dri2"
[ 20.384] (II) LoadModule: "fglrx"
[ 20.385] (II) LoadModule: "ati"
[ 20.426] (II) LoadModule: "radeon"
[ 20.488] (II) LoadModule: "vesa"
[ 20.489] (II) LoadModule: "fbdev"
[ 20.517] (II) LoadModule: "fglrx"
[ 20.518] (II) LoadModule: "ati"
[ 20.518] (II) LoadModule: "vesa"
[ 20.518] (II) LoadModule: "fbdev"
[ 20.525] (II) LoadModule: "fbdevhw"
[ 20.662] (II) LoadModule: "exa"
[ 21.275] (II) LoadModule: "fb"
[ 21.293] (II) LoadModule: "ramdac"
[ 23.338] (II) LoadModule: "evdev"
[ 23.376] (II) LoadModule: "synaptics"

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-08-24
Last query:
2012-08-24
Last reply:
2012-08-24

Can you give the output of:

lsb_release -a; dpkg -l | grep fglrx

Thanks

jobra (jobra) said : #2

hi Andrew, thank you for the response. Here is the output:

 lsb_release -a; dpkg -l | grep fglrx
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

thank you.

You are using the open source driver. Use this to install the proprietary fglrx driver and it should help:
https://help.ubuntu.com/community/BinaryDriverHowto/ATI

jobra (jobra) said : #4

Thanks actionparsnip, that solved my question.