can't install UBUNTU because of ATI HD6870

Asked by Parley Applegate on 2012-07-10

Have been trying to install IBUNTU for a month. Many of the inputs must be for other versions as they suggest doing things that are not available for me to do. Tried to install over Windows7 but failed to produce a GRUP. Wiped disk clean with Acronis and installed 11.10 to end up with a blank screen. Can boot from disk but not from installed system. Tried using 12.02, but then can't boot from disk. I hear of a VGA mode but appearently it is not supported by 11.10. The problem seems to be a new ATI card - HD6870. So new that the boxed drivers will not boot using Windows7. Had to download new driver for Windows7. Tried the ATI driver for IBUNTU (took forever to run) but would not complete.
System is on Sabertook 990FX motherboard with 4GB memory, 100GB SSD, 120GB HDD, VGA Sapphire 10031rFles HD6870 R display card.

Is there a method of forcing the installation to use only the VGA?

Has other installed ATI's driver for HD6870 on their 11.10 system?

Wiped the drive clean and reinstalled Windows7. Where should I go from here?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
Parley Applegate
Solved:
2012-07-11
Last query:
2012-07-11
Last reply:
WinLinUser (winlinuser-gmail) said : #1

Hi
I have a similar problem with 10.02 and my ATI HD5450 card / DELL monitor. I get a "can't display this resolution" type message on the monitor. It's the same when I try to use Mint 9 although 10 and 12 work fine.

You could try using SHIFT after the initial POST screen on startup. This should let you select a boot using "safe graphics". From there you can de install the ATI drivers. Perhaps this will work for you
(incidently, I'm no expert with linux but have had to mess with the system)

Otherwise, I have used the following in the terminal to remove ATI drivers and it appears to work in Mint as a way of triggering the default drivers:

sudo apt-get remove --purge fglrx*

sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon

sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

sudo dpkg-reconfigure xserver-xorg

Reboot your computer.

Hope this works for you :-D

Parley Applegate (p-apple) said : #2

thank for the advice