My screen is all messed up

Asked by Nicholas Gruepala on 2012-05-29

Yes i have installed Lubuntu 12.04 and im using it but i have two screens....My graphics card is a 128 rage agp 2x and i dont know if it installed when i installed Lubuntu but i have like a static crap with two mouse pointers and its driving me nuts

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
Nicholas Gruepala
Solved:
2012-05-31
Last query:
2012-05-31
Last reply:
2012-05-30

its like i have two shut down icons one on the left and one on the right bottom i dont know what is happening

I tried to screen shot the problem but it shows up as nothing is wrong but i see it...

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; xrandr

Thanks

how do i do that i am a newb

Copy the command and press CTTRL+ALT+T
Paste the command to terminal and hit ENTER
type your password (you will get no feedback, this is to hide length) and hit ENTER
Copy the output and paste here as an update

Thanks

http://i1059.photobucket.com/albums/t435/thejoker4011/103_0425.jpg

there is a picture of what it looks like....i had to take with my camera cause when i print screen it shows nothing wrong....
i will get the output here in a few...hope the pic helps out alot..thanks

Have you tried blacklisting the driver module in use?

How do i do that? and here is the OUTPUT you requested

  *-display UNCLAIMED
       description: VGA compatible controller
       product: Rage Mobility M3 AGP 2x
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 02
       width: 32 bits
       clock: 66MHz
       capabilities: agp agp-2.0 pm vga_controller bus_master cap_list
       configuration: latency=66 mingnt=8
       resources: memory:f8000000-fbffffff ioport:2000(size=256) memory:f4100000-f4103fff memory:f4120000-f413ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux Starfleet 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:41:14 UTC 2012 i686 i686 i386 GNU/Linux
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768 60.0*
   800x600 60.0 56.0
   640x480 60.0

Hmm, no driver loaded. Interesting.

Run:

gksudo gedit /etc/X11/xorg.conf

add the below code:

Section "Monitor"
        Identifier "laptop LCD"
        VendorName "Laptop"
        ModelName "Laptop"
        HorizSync 31.5-48.5
        VertRefresh 40-70
EndSection

Section "Device"
        Identifier "Video0"
        Driver "r128"
        VideoRam 8192
        Option "EnablePageFlip" "true"
        Option "AGPFastWrite" "true"
        Option "AGPMode" "2"
        BusID "PCI:01:00:0"
        Screen 0
        Option "Display" "FP"
        Option "MonitorLayout" "CRT, LFP"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device "Video0"
        Monitor "laptop LCD"
        DefaultDepth 16
        Subsection "Display"
                Depth 32
                Modes "1024x768"
        EndSubSection
        Subsection "Display"
                Depth 24
                Modes "1024x768"
        EndSubSection
        Subsection "Display"
                Depth 16
                Modes "1024x768"
        EndSubSection
        Subsection "Display"
                Depth 8
                Modes "1024x768"
        EndSubSection
EndSection

Section "DRI"
        Mode 0666
EndSection

Section "Monitor"
    Identifier "external LCD"
    Option "DPMS"
End Section

Section "Device"
    Identifier "Video1"
    Driver "r128"
    VideoRam 8192
    BusID "PCI:01:00:0"
    Option "Display" "FP"
    Screen 1
EndSection

Section "Screen"
    Identifier "Screen1"
    Device "Video1"
    Monitor "external LCD"
    DefaultDepth 16
    SubSection "Display"
        Depth 8
        Modes "1024x768"
    EndSubSection
    SubSection "Display"
        Depth 16
        Modes "1024x768"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier "Multihead"
    Screen 0 "Screen0"
    Screen 1 "Screen1" rightof "Screen0"
EndSection

Section "ServerFlags"
    Option "xinerama" "true"
    Option "DefaultServerLayout" "Multihead"
EndSection

Save the new file and close gedt then reboot, if you get no display, hold shift at boot, select recovery mode and select root and run:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old
reboot

HTH

so i select run for the menu and paste gksudo gedit /etc/X11/xorg.conf into it and copy all that coding and paste it in the thing that opens from the run program?

cant figure this out cause i put
gksudo gedit /etc/X11/xorg.conf

in the run command and nothing comes up after i put in my password...any more help would be great...Thanks

ok try:

gksudo leafpad /etc/X11/xorg.conf

Forgot you were using LXDE :)

i did the
gksudo leafpad /etc/X11/xorg.conf

there was nothing in the thing so i copy and pasted the whole code you told me to and now it just hangs at the Lubuntu loading screen....i cant log in or anything

i take it there is no fix for this?

You will just need to code an xorg.conf file much like the one I gave above.

i dont know how to code.....im a newb to ubuntu....is there somewhere i cant get a code or something?

opened up a new question