Ubuntu

Laptop runs hot with Radeon drivers

Asked by African Somo on 2012-04-28

Currently using Ubuntu 12.04 x64 bit with Gnome classic.
Laptop runs hot using open source Radeon drivers and cuts battery life in half.
Runs cooler with fglrx drivers, though, the drivers are broken and I can't play games using them.
This issue occurs on any distro I use.

System:

Alienware M17x-R3
i7-2630Q
6GB 1333 RAM
320GB HDD
AMD HD 6970M 2GB

I am able to play games with the radeon drivers, though I get temperatures of about 70 C, as opposed to around 55 C with fglrx.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-29
Last reply:
2012-04-30

Alienware are known for running hot anyway.

Sounds like you have that switchable graphics nonsense. That causes a LOT of issues in Linux. There is a project called IronHide to support it but I've never heard a single success story with it

Well, like I said, using proprietary graphics, the temperatures aren't that bad. Though, the drivers are broken and don't allow me to run any game at all.
I've also looked into Ironhide. I never tried it because, as you say, not many people say that it works.

I can't believe I've never found that solution before (The one in related bugs) about changing the power_profile. Changing it from default to mid drastically improved my temps. I suppose I'll mark this as solved.

Actually, Now I have an issue where it resets to default each time I reset my PC. Is there anyway to keep that setting?

AlexAD (alex-ad) said : #5

If you run
     sudo cat /sys/kernel/debug/vgaswitcheroo/switch
You will probably see something like:
     0:IGD:+:Pwr:0000:01:05.0
     1:DIS: :Pwr:0000:02:00.0

now run
    sudo echo OFF |sudo tee /sys/kernel/debug/vgaswitcheroo/switch
and then
     sudo cat /sys/kernel/debug/vgaswitcheroo/switch
     0:IGD:+:Pwr:0000:01:05.0
     1:DIS: :Off:0000:02:00.0
The discrete card is no powered down and the laptop should return to normal heat you probably know that acpi -t will tell you the current tempature.

To make this work around automatic try adding the following lines to /etc/rc.local

modprobe radeon
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

obviously before the exit 0

Some notes:
- You can use vgaswitcheroo to change to the discrete graphics card
        - To switch to the discrete user the following – it wont change it on the fly
              sudo echo "DIS"| sudo tee /sys/kernel/debug/vgaswitcheroo/switch
        - To switch on the next restart use
              sudo echo "DDIS"| sudo tee /sys/kernel/debug/vgaswitcheroo/switch
        - To switch back to onboard try
              sudo echo IGD | sudo tee /sys/kernel/debug/vgaswitcheroo/switch
- the open source drivers do run hotter than the AMD/ATI ones

Can you help with this problem?

Provide an answer of your own, or ask African Somo for more information if necessary.

To post a message you must log in.