Install Ubuntu 10.04 on powerpc ibook g3

Asked by rob fabian on 2010-07-27

Ok,
I created an installation cd of 10.04 powerpc. I managed to get the mac to boot off the cd and ubuntu ran successfully. I have tried to install the software onto the hard disk but have hit a snag.
The software appeared to install correctly but I cant boot into the gui.
The system boots up as far as the ubunto logo and moving dots. When these disappear I get a blank screen and the computer just sits there.
If I hit ctrl-option-f1 I can get to the terminal.
I am told it might be a problem with the xorg.conf file (which the system does not generate) The graphics card appears to be a ati m7 lw radeon mobility 7500.
Any ideas ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-ati Edit question
Assignee:
No assignee Edit question
Solved by:
rob fabian
Solved:
2010-07-27
Last query:
2010-07-27
Last reply:
2010-07-27
Jim Bauwens (jimbauwens) said : #1

Hi,try https://help.ubuntu.com/community/RadeonDriver, it might help.
And also, did the you have graphics in the live cd, or did you use an alternate cd?

Jim Bauwens (jimbauwens) said : #2

Look also at :https://wiki.ubuntu.com/X/KernelModeSetting, maybe disable KMS will help.

Good luck :)

rob fabian (rob-halotech) said : #3

Ok, thanks for your help. In the end I just added ubuntu netbook remix over the top and the gui worked. That will do for me on this ibook.