Mouse not working

Asked by Paperwise on 2017-08-31

I have a surface pro 3. When booting up Ubuntu, my mouse has no cursor and doesn't work. I also tried connecting a Bluetooth mouse and it also doesn't work. I was only able to install Ubuntu using my touch screen. I have tried several answers to posts of people with the same problem with no success.

Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-input-synaptics Edit question
Assignee:
No assignee Edit question
Last query:
2017-09-01
Last reply:
2017-09-01

If you press CTRL + ALT +T you will bring up a terminal. You can then update using:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo reboot

If you log in as guest is it OK?
Which release did you install?

Paperwise (krzysztof94) said : #3

Thank you for promo responses. I am using 16.04.3 LTS. I tried first recommendation above and cursor still didn't appear. Logging in as a guest did not work either. When I enter password to log in, a cursor appears which I can't move, then it disappears once the desktop loads. Thanks again.

Paperwise (krzysztof94) said : #4

Also right clicking works but I cannot see cursor.

Typing your password using sudo gives no feedback but the entry is happening

Can you help with this problem?

Provide an answer of your own, or ask Paperwise for more information if necessary.

To post a message you must log in.