lenovo n22 ideapad keyboard not working in BIOS, bootloader

Asked by j on 2017-03-21

Lenovo N22 80S6 thinkpad touchpad+keyboard not working in bios /anywhere including "live cd" of #! , mint ,tahr puppy. minino.
both touchpad and keyboard worked from date of purchase 11/2016 til last week in linux mint 18 after got sdcard reader working / did system updates. i had just finished resolving the matter of the sdcard reader not working so i suspect that process is the number 1 culprit but there were so many steps taken to get that fixed that i have no idea how to undo that work even if it would fix this problem.
info accumulated after researching this for past week:
uefi system
SKU Number: LENOVO_MT_80S6_BU_idea_FM_Lenovo N22 Family: IDEAPAD

tried:
Checked for any bios settings regarding touchpad or keyboards (bios has only one setting related to touchpad+keyboard which ws for enabling function hotkeys , i disabled, rebooted = no chg, re-enabled, rebooted= no chg )
unplugged external keyboard and rebooted
upraded from mint 18 to 18.1 to attempt fix but failed
neither touchpad nor keyboard working when doing this:
Fn + F8 touchpad lock/unlock
Fn + F6 keyboard lock/unlock
booted into livecd
changed bios seting from uefi to legacy and that let me boot into other live cd's but neither touchpad nor keyboard worked there

Other Notes:
External usb keyboard&mouse work perfectly
The laptop keyboard&touchpad worked unti ~3/14
No recent changes come to mind that could've triggered this. Maybe a linux update?
BIOS menu can be entered (fn+F2) using the usb keyboard, but it can't be used for anything else

brings up mouse and keyboard settings but only shows usb ones:
holiday@holiday-Lenovo ~ $ xfce4-mouse-settings

What version of xfce4-settings is installed?:
holiday@holiday-Lenovo ~ $ apt-cache policy xfce4-settings
xfce4-settings:
  Installed: 4.12.0-2ubuntu1
  Candidate: 4.12.0-2ubuntu1
  Version table:
 *** 4.12.0-2ubuntu1 500
        500 http://ftp.usf.edu/pub/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

What video card and which driver are you using? :
holiday@holiday-Lenovo ~ $ lspci -v | grep -A10 VGA
00:02.0 VGA compatible controller: Intel Corporation Device 22b1 (rev 21) (prog-if 00 [VGA controller])
 Subsystem: Lenovo Device 3808
 Flags: bus master, fast devsel, latency 0, IRQ 117
 Memory at 90000000 (64-bit, non-prefetchable) [size=16M]
 Memory at 80000000 (64-bit, prefetchable) [size=256M]
 I/O ports at 1000 [size=64]
 [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915

cat /proc/bus/input/devices does not show the touchpad or keyboard:

holiday@holiday-Lenovo ~ $ cat /proc/bus/input/devices

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
U: Uniq=
H: Handlers=event0
B: PROP=0
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1
U: Uniq=
H: Handlers=kbd event1
B: PROP=0
B: EV=3
B: KEY=10000000000000 0

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
U: Uniq=
H: Handlers=kbd event2
B: PROP=0
B: EV=3
B: KEY=10000000000000 0

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input6
U: Uniq=
H: Handlers=kbd event3
B: PROP=0
B: EV=3
B: KEY=3e000b00000000 0 0 0

I: Bus=0003 Vendor=413c Product=3012 Version=0111
N: Name="Dell Dell USB Optical Mouse"
P: Phys=usb-0000:00:14.0-2/input0
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.0/0003:413C:3012.0001/input/input7
U: Uniq=
H: Handlers=mouse0 event4
B: PROP=0
B: EV=17
B: KEY=70000 0 0 0 0
B: REL=103
B: MSC=10

I: Bus=0003 Vendor=04d9 Product=1503 Version=0110
N: Name="USB Keyboard"
P: Phys=usb-0000:00:14.0-4/input0
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/0003:04D9:1503.0002/input/input8
U: Uniq=
H: Handlers=sysrq kbd event5 leds
B: PROP=0
B: EV=120013
B: KEY=1000000000007 ff800000000007ff febeffdff3cfffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0003 Vendor=04d9 Product=1503 Version=0110
N: Name="USB Keyboard"
P: Phys=usb-0000:00:14.0-4/input1
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.1/0003:04D9:1503.0003/input/input9
U: Uniq=
H: Handlers=kbd event6
B: PROP=0
B: EV=1f
B: KEY=3007f 0 0 483ffff17aff32d bf54444600000000 1 130c130b17c000 267bfad941dfed 9e168000004400 10000002
B: REL=40
B: ABS=100000000
B: MSC=10

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name="Ideapad extra buttons"
P: Phys=ideapad/input0
S: Sysfs=/devices/pci0000:00/0000:00:1f.0/PNP0C09:00/VPC2004:00/input/input10
U: Uniq=
H: Handlers=rfkill kbd event7
B: PROP=0
B: EV=13
B: KEY=101400800100c03 400000000300000 0 2
B: MSC=10

I: Bus=0003 Vendor=04f2 Product=b582 Version=8737
N: Name="Lenovo EasyCamera"
P: Phys=usb-0000:00:14.0-5/button
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/input/input13
U: Uniq=
H: Handlers=kbd event8
B: PROP=0
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH Mic"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card0/input11
U: Uniq=
H: Handlers=event9
B: PROP=0
B: EV=21
B: SW=10

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH Headphone"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card0/input12
U: Uniq=
H: Handlers=event10
B: PROP=0
B: EV=21
B: SW=4

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH HDMI/DP,pcm=3"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card0/input14
U: Uniq=
H: Handlers=event11
B: PROP=0
B: EV=21
B: SW=140

xinput list also does not show either device:

holiday@holiday-Lenovo ~ $ xinput

⎡ Virtual core pointer id=2 [master pointer (3)]

⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]

⎜ ↳ Dell Dell USB Optical Mouse id=9 [slave pointer (2)]

⎜ ↳ USB Keyboard id=11 [slave pointer (2)]

⎣ Virtual core keyboard id=3 [master keyboard (2)]

    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]

    ↳ Power Button id=6 [slave keyboard (3)]

    ↳ Video Bus id=7 [slave keyboard (3)]

    ↳ Power Button id=8 [slave keyboard (3)]

    ↳ USB Keyboard id=10 [slave keyboard (3)]

    ↳ Lenovo EasyCamera id=12 [slave keyboard (3)]

    ↳ Ideapad extra buttons id=13 [slave keyboard (3)]

output of sudo dmidecode -t 1; lsb_release -a; uname -a :

holiday@holiday-Lenovo ~ $ sudo dmidecode -t 1; lsb_release -a; uname -a

[sudo] password for holiday:

# dmidecode 3.0

Getting SMBIOS data from sysfs.

SMBIOS 2.7 present.

Handle 0x0001, DMI type 1, 27 bytes

System Information

 Manufacturer: LENOVO

 Product Name: 80S6

 Version: Lenovo N22

 Serial Number: YD00MZ2N

 UUID: D3CF9158-181E-1620-0308-182553000000

 Wake-up Type: Power Switch

 SKU Number: LENOVO_MT_80S6_BU_idea_FM_Lenovo N22

 Family: IDEAPAD

No LSB modules are available.

Distributor ID: LinuxMint

Description: Linux Mint 18.1 Serena

Release: 18.1

Codename: serena

Linux holiday-Lenovo 4.8.0-42-generic #45~16.04.1-Ubuntu SMP Thu Mar 9 14:10:58 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-input-synaptics Edit question
Assignee:
No assignee Edit question
Last query:
2017-03-21
Last reply:
2017-03-21
Manfred Hampl (m-hampl) said : #1

Linux Mint is not supported here (the same for all other operating systems that are "based on" Ubuntu).

Please look at https://www.linuxmint.com/contactus.php for support, e.g. https://forums.linuxmint.com/

j (f44w9zx3z) said : #2

hello, i started with mint support but they said this is not a mint problem, why won't keyboard work in bios?

Manfred Hampl (m-hampl) said : #3

Any why should it be an Ubuntu problem if you are running Linux Mint?

j (f44w9zx3z) said : #4

who will help with keyboard not working in bios ?

Manfred Hampl (m-hampl) said : #5

If the keyboard does not work in BIOS setup, then it is a BIOS problem, and you should refer to the manufacturer.
And of course a hardware problem on the keyboard and/or its cabling is also a potential cause.

j (f44w9zx3z) said : #6

 can you tell me who the bios manuf is and where to contact them for help with this . thank you.

Manfred Hampl (m-hampl) said : #7

ask lenovo

Can you help with this problem?

Provide an answer of your own, or ask j for more information if necessary.

To post a message you must log in.