Keyboard/Mouse slow when connected to other usb ports

Asked by Kabeer Ahmed on 2008-08-14

Hi,

I have a Toshiba Satellite M45 laptop. The screen has got issues. So I have decided to use it as a desktop by connecting the usb keyboard and a usb mouse to the laptop using a LCD monitor.

There are 3 usb ports to the laptop.

When the keyboard or mouse is connected to one port, they work fine. Other than this port if they are connected to any of the remaining 2 usb ports, they work very very slow. It seems like they miss the input.

Due to this I am not able to use laptop smoothly. Any ideas or suggestions. Please guide me through any logs you require and I shall be more than happy to contribute.

Thanks,
Kabeer Ahmed.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-synaptics Edit question
Assignee:
No assignee Edit question
Solved by:
Kabeer Ahmed
Solved:
2008-08-17
Last query:
2008-08-17
Last reply:
2008-08-14

It must be a hardware problem. check with another mouse or keyboard. or if you can use windows try on it. maybe you'll have to fix your computer

Kabeer Ahmed (smdahmed) said : #2

Hi Martin Martinez,

Many thanks for your quick respose.

Prior to installing Linux I have been using this Laptop which came with Microsoft Windows Home Edition and usb keyboard and usb mouse were working perfectly.

Just to add, if I disconnect the usb keyboard or mouse once the system is up and running & reconnect; I will have to reboot the entire PC to detect the keyboard and or mouse.

So this looks like there is an issue somewhere.

Thanks for all your help,
Kabeer.

Kabeer Ahmed (smdahmed) said : #3

I could find another thread where another user is listing down similar problem:
http://ubuntuforums.org/showthread.php?t=825036

 Slow mouse+USB mount+Audio/Video+Printer
Hi,

I have Ubuntu 8.04 installed on my Toshiba Satellite laptop. It works almost perfectly.

10% of the time, everything works. The other 90% of the time these problems occur:

A) Touchpad works fine, but USB mouse reacts VERY slowly.
B) USB drives are not recognized upon insertion
C) Printing to my Brother MFC-210C printer is VERY slow
D) Audio and Video on the internet cannot be played due to “Invalid Stream”

This “choice” seems to be made upon booting up. And it all occurs together. It all works or none of it does. What could be affecting all of these things and apparently nothing else? I don’t know of anything I’m doing different. There is no difference if I shut down, hibernate, or suspend the system.

Any help or advice anyone can offer? Is there anymore info I can give you that would help?

Thanks,

Jon

Kabeer Ahmed (smdahmed) said : #4

Ok, I have finally arrived at the solution but in a very mysterious way :).

I have a desktop working fine with Ubuntu Studio where the same key board and mouse worked fine. So I thought to load the laptop too with the same Ubuntu studio and test it.

I guess thats the thing that worked.

Ubuntu when installed on the laptop installed Linux 2.6.24-generic but somehow Ubuntu studio has installed Linux 2.6.24-rt. Once I boot with the option of Linux 2.6.24-rt, I get all my keyboard and mouse working.

And I can plug in and plug out the usb key board and mouse.

Thanks for your help but I guess there is some issue with Ubuntu installation. I am more than happy to help and provide a log.

Or please clarify if someone has to select this module if his computer has get this RT module. Atleast I still dont understand the difference but the issue now seems to have got solved.

thanks for all the help.