Synaptics touchpad stopped working. Ubuntu 12.04. Acer Aspire 4749

Asked by mariki zietsman on 2012-11-30

My Synaptics touchpad stopped workig randomly (maybe after updating software). A usb ouse still works fine. Switching to a guest user doesn't help and neither did lockking and unlocking te touchpad with Fn+F7.

I'm still quite new to Ubuntu and have tried out some solutions suggested in reply to similar questions eg. echo "options psmouse proto=imps"|sudo tee /etc/modprobe.d/mousefix.conf>/dev/null and rebooting but this didn't work.

I also tried installing an accesory "Touchpad-Indicator" thinking it miht help to see what the problem was, and when I realised it wasn´ t really of any use tried uninstalling it with sudo apt-get autoremove. After removing this accesory Fn+F7 doesn't seem to turn the touchpad on anymore, but this isn't the originnal problem.

Thanks a lot
Mik

re-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

Linux -Aspire-4749 3.2.0-33-generic #52-Ubuntu SMP Thu Oct 18 16:29:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

[ 1.043507] mousedev: PS/2 mouse device common for all mice
[ 2.157732] input: USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input5
[ 2.157831] generic-usb 0003:15D9:0A4C.0001: input,hidraw0: USB HID v1.11 Mouse [ USB OPTICAL MOUSE] on usb-0000:00:1d.0-1.2/input0
[ 18.125213] input: PS/2 Synaptics TouchPad as /devices/platform/i8042/serio2/input/input9
[ 42.155474] input: USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input13
[ 42.155630] generic-usb 0003:15D9:0A4C.0002: input,hidraw0: USB HID v1.11 Mouse [ USB OPTICAL MOUSE] on usb-0000:00:1d.0-1.2/input0
[ 51.762499] input: USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input14
[ 51.762656] generic-usb 0003:15D9:0A4C.0003: input,hidraw0: USB HID v1.11 Mouse [ USB OPTICAL MOUSE] on usb-0000:00:1d.0-1.2/input0
[ 969.368393] input: USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input15
[ 969.368794] generic-usb 0003:15D9:0A4C.0004: input,hidraw0: USB HID v1.11 Mouse [ USB OPTICAL MOUSE] on usb-0000:00:1d.0-1.2/input0
[ 987.447340] input: USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input16
[ 987.447660] generic-usb 0003:15D9:0A4C.0005: input,hidraw0: USB HID v1.11 Mouse [ USB OPTICAL MOUSE] on usb-0000:00:1d.0-1.2/input0
[ 1249.418255] psmouse serio2: TouchPad at isa0060/serio2/input0 lost synchronization, throwing 1 bytes away.
[ 1261.994752] psmouse serio2: TouchPad at isa0060/serio2/input0 lost synchronization, throwing 1 bytes away.
[ 1275.835098] input: USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input17
[ 1275.835720] generic-usb 0003:15D9:0A4C.0006: input,hidraw0: USB HID v1.11 Mouse [ USB OPTICAL MOUSE] on usb-0000:00:1d.0-1.2/input0
[ 1289.637009] psmouse serio2: TouchPad at isa0060/serio2/input0 lost synchronization, throwing 1 bytes away.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-synaptics Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-11-30
Last query:
2012-11-30
Last reply:
2012-11-30

Try:

echo "options psmouse proto=raw" |sudo tee /etc/modprobe.d/mousefix.conf>/dev/null

mariki zietsman (morgandetoi) said : #2

Thanks actionparsnip, that solved my question.

mariki zietsman (morgandetoi) said : #3

Brilliant! Thanks! Would it be a pain to quickly explain what went wrong?

The module needs an option to work properly. The default doesn't work for your hardware. The file you made simply tells the OS to use that option by default every time the module is loaded.

mariki zietsman (morgandetoi) said : #5

Thanks again