Touchpad oversensitive in fullscreen apps

Asked by Matthew on 2012-06-18

This has been an ongoing problem for a while now. Whenever you enter a fullscreen app such as a game the mouse is insanely sensitive. This happens with every laptop I use ubuntu 12.04 64bit on. It also occurs on Ubuntu 12.04 32 bit. it makes it a pain to get into game menus and such. Any tips on how to adjust the sensitivity? The touchpad options in the system settings does NOT work.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-synaptics Edit question
Assignee:
No assignee Edit question
Solved by:
Tim Cussins
Solved:
2012-09-13
Last query:
2012-09-13
Last reply:
2012-09-12

Is this on a laptop?

Matthew (ruinairas1992) said : #2

" This happens with every laptop I use ubuntu 12.04 64bit on. It also occurs on Ubuntu 12.04 32 bit" so yes on a laptop :D

Sam_ (and-sam) said : #3

> touchpad options in the system settings does NOT work.

If something doesn't work as expected report a bug please.
Rather review bug reports if it's a known issue.

Can you please tell us the make and model.......you have left the MOT crucial piece of information out here....

Think about it.....

Matthew (ruinairas1992) said : #5

This happens with any type of laptop I use. The one I'm currently using is a Compaq Presario CQ57-339WM. I'm sure if you were to launch a game like Super Maryo Chronicles on any of your laptops you'll see the problem that is occuring. The reason I ask the question here is because I've seen bug reports all the way back to Lucid that weren't fixed so I thought maybe it was just something I am doing wrong rather than a bug.

Wy did you nott state the make and model of the ststem until now?

*system

Try:

gksudo gedit /etc/X11/xorg.conf

Add the below lies and reboot:

Section "InputDevice"
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/psaux"
    Option "Protocol" "auto-dev"
    Option "HorizEdgeScroll" "0"
    Option "MinSpeed" "1.0"
    Option "MaxSpeed" "1.8"
    Option "AccelFactor" "0.3"
    Option "MaxTapTime" "0"
EndSection

Matthew (ruinairas1992) said : #9

I tried it and it doesn't appear to work. When a game or application is run in windowed mode it works fine. As soon as I open it up to fullscreen it goes crazy. It acts as though the resolution has changed, but the input settings stay the same as the default settings. Also the reason why I didn't put an exact model number is because I maintain my friend's and families computers and I don't know the exact models off hand.

Sorry for the confusion :(

You could report a bug

Sam_ (and-sam) said : #11

> bug reports all the way back to Lucid that weren't fixed

Please collect those and post it in the new one maybe they have something in common.
Hopefully finally someone works all away through til the cause.

Best Tim Cussins (skz) said : #12

Hi all,

I've traced the problem to SDL1.2

When a game hides the cursor (i.e. SDL_ShowCursor(SDL_DISABLE)) SDL switches to relative mouse mode, and the fun begins.

You can inhibit this behaviour by ensuring that the SDL_MOUSE_RELATIVE environment variable is set to 0

Open a terminal, type:

export SDL_MOUSE_RELATIVE=0

the run your game e.g. :

hedgewars

You should find your problem is gone :)

Hope this helps.

Tim

Matthew (ruinairas1992) said : #13

Thanks Tim Cussins, that solved my question.

You should run:

echo "SDL_MOUSE_RELATIVE=0" | sudo tee -a /etc/environment > /dev/null

and it will apply the setting at boot and also apply to all future system users :)

Tim Cussins (skz) said : #15

I actually put a line in ~/.pam_environment for now.

It's not clear whether setting this variable to 0 will negatively impact any other applications. The SDL source code makes it clear that people won't want to override the default behaviour like we have:

From SDL_x11mouse.c
 /* Allow the user to override the relative mouse mode.
    They almost never want to do this, as it seriously affects
    applications that rely on continuous relative mouse motion.
 */

So yeah, maybe setting it system-wide could cause problems for other apps, leading to a bug reports about fullscreen SDL apps that used to work, and now are broken.

What would be best is for per-app override of the variable... Not sure how to do this in a simple way though.