touchpad not working in 12.04

Asked by David Nilsson on 2012-05-10

a few days after upgrade to 12.04 the touchpad stopped working. External mouse is working, keybord is working and i can toggle the touchpad on/off (as it appears on the screen)

computer: Asus eee 1001px

david@david-1001PX:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Avant Com ViSta Mouse id=10 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=14 [slave pointer (2)]

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu xserver-xorg-input-synaptics Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-10
Last reply:
2012-06-06

can you give the output of:

lsmod

Thanks

David Nilsson (kdknilsson) said : #2

Module Size Used by
bnep 17830 2
rfcomm 38139 0
bluetooth 158438 10 bnep,rfcomm
parport_pc 32114 0
ppdev 12849 0
binfmt_misc 17292 1
uvcvideo 67203 0
videodev 86588 1 uvcvideo
snd_hda_codec_realtek 174055 1
usbhid 41906 0
hid 77367 1 usbhid
arc4 12473 2
joydev 17393 0
snd_hda_intel 32765 5
ath9k 117326 0
snd_hda_codec 109562 2 snd_hda_codec_realtek,snd_hda_intel
mac80211 436455 1 ath9k
snd_hwdep 13276 1 snd_hda_codec
snd_pcm 80845 3 snd_hda_intel,snd_hda_codec
snd_seq_midi 13132 0
eeepc_wmi 12949 0
snd_rawmidi 25424 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
ath9k_common 13781 1 ath9k
snd_seq 51567 2 snd_seq_midi,snd_seq_midi_event
asus_wmi 19624 1 eeepc_wmi
sparse_keymap 13658 1 asus_wmi
ath9k_hw 391523 2 ath9k,ath9k_common
ath 19387 3 ath9k,ath9k_common,ath9k_hw
snd_timer 28931 2 snd_pcm,snd_seq
snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
cfg80211 178679 3 ath9k,mac80211,ath
psmouse 72919 0
serio_raw 13027 0
i915 414603 2
snd 62064 18 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
drm_kms_helper 45466 1 i915
drm 197692 3 i915,drm_kms_helper
mac_hid 13077 0
i2c_algo_bit 13199 1 i915
soundcore 14635 1 snd
video 19068 1 i915
wmi 18744 1 asus_wmi
snd_page_alloc 14108 2 snd_hda_intel,snd_pcm
lp 17455 0
parport 40930 3 parport_pc,ppdev,lp
atl1c 36718 0

David Nilsson (kdknilsson) said : #5

I think it's the following bug i'm experiencing:
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/989689

But how do I check if I have multiple syndaemon running?
https://bugs.launchpad.net/ubuntu/+bug/862703

Anthony Wong (anthonywong) said : #6

If you uncheck the option "Disable touchpad while typing" in System Settings, does it help?

Ckon Mapy (koupykon) said : #7

Hi! I am living the same experience and in my settings there is no more the tab for unchecking "Disable touchpad while typing" it has just disapeared... I really don't know why?!?

Can you help with this problem?

Provide an answer of your own, or ask David Nilsson for more information if necessary.

To post a message you must log in.