synclient TouchPadOff=1 doesn't work

Asked by Steve Heflin on 2012-05-03

After installing Ubuntu 10.04 32bit on my LinuxCertified notebook, I can't get the blasted touchpad turned off. When I run Fedora-15 or 16 on the same machine, the command "synclient TouchPadOff=1" works perfectly. Can anybody help me to get it working with Ubuntu?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-synaptics Edit question
Assignee:
No assignee Edit question
Solved by:
Wyatt Smith
Solved:
2012-05-11
Last query:
2012-05-11
Last reply:
2012-05-08
Wyatt Smith (wyatt-smith) said : #1

Here is a link to the Ubuntu Community Document regarding Touchpad.
https://help.ubuntu.com/community/SynapticsTouchpad

You can disable the touchpad with the xinput command using the device id as a parameter.

Steve Heflin (sheflin) said : #2

The instructions work just fine, however, I would like a way to automate it so that I don't have to run the command every time I long in. I tried adding it to my login script but it doesn't work.

Wyatt Smith (wyatt-smith) said : #3

Try adding the command to session startup

To open the sessions tool
ALT+F2
gnome-session-properties

Steve Heflin (sheflin) said : #4

ALT+F2 opens a "Run Command" dialog. No "gnome-session-properties" appears anywhere.

Wyatt Smith (wyatt-smith) said : #5

Sorry if I was unclear. Run the following command from terminal or ATL+F2

gnome-session-properties

This will open the start application utility. Hit the Add button. On the command line, insert your xinput command. The will allow it to run each time you login.

Steve Heflin (sheflin) said : #6

Ah I see what you meant now. Unfortunately, the touchpad is still alive and interfering with my typing. The command has to have been run, but there must be something that runs afterward that enables it again. So far I've run it from .bash_profile , /etc/profile.d , and now gnome-session-properties. The only way I've been able to shut off the touchpad is by opening a terminal window and running the command.

Best Wyatt Smith (wyatt-smith) said : #7

Maybe you can try a different approach. Another way of handling this is to remove/blacklist the kernel module.

You can remove the kernel module with
sudo modprobe -r psmouse

This will be temporary like your current xinput command. To make it permanent, you will need to blacklist it. As superuser you will need to create the following file /etc/modprobe.d/blacklist-touchpad.conf. Add the following line
blacklist psmouse

Hope this helps

Steve Heflin (sheflin) said : #8

Thanks Wyatt Smith, that solved my question.