Sony Vaio VPCEG1BFX laptop: Pointing Device Issue

Asked by Brad Willis on 2012-03-29

Is anybody else experiencing a failure to operate in your pointing device with Ubuntu 11.10? I recently installed it on my Sony Vaio VPCEG1BFX laptop, and at least once or twice every time I boot up with Ubuntu, my pointing device just stops working and the only apparent way I can get it to go again is to turn off the PC, and turn it back on again. Is there a fix for this, or maybe an easier way to correct it without turning off the machine?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-input-synaptics Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-08
Last reply:
2012-04-08

This question was reopened

Run:

gksudo gedit /etc/default/grub

Find the line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

And change it to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8024.nomux=1"

Save the new file, close gedit and run:

sudo update-grub

Reboot to test.

If that is no good try:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8024.nopnp"

Instead.

Brad Willis (guiternity) said : #3

Thank you,....I went ahead and did the first one, but it will take a few days for me to see how the pointing device is going to act as a result. If I still have problems, I'll try the second suggestion. I'm going to close out this string as problem solved, but will contact you again if neither suggestion works. Thank you so much for the assist. :)

Brad Willis (guiternity) said : #4

Thanks actionparsnip, that solved my question.

Yeah those dumb Sony Vaios need this, quick and easy to solve if you know.

Brad Willis (guiternity) said : #6

Ok,....I tried the first suggestion of - GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8024.nomux=1" - and it seemed to improve the performance of my pointing device,....but lately, it has started the stopping thing again. So, I went ahead and tried the second suggestion of - GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8024.nopnp" - and it produced horrible results, with this one, the pointing device only worked long enough to log in, and immediately stopped,....three boot up's in a row. So, I set it back to the first suggestion, and am wandering if there's any other option here, as the first thing sort of "semi-fixed" it, but it isn't consistent.

I suggest you report a bug. Sony Vaio touchpads are garbage

Can you help with this problem?

Provide an answer of your own, or ask Brad Willis for more information if necessary.

To post a message you must log in.