Can't disable Dell inspiron N5110 touchpad tap to click

Asked by Matthew Gilzinger on 2012-01-25

I installed Ubuntu 11.10 on my Dell Inspiron N5110 When I go to mouse and touchpad settings, there is only one tab, Mouse. The touchpad 'works'. It moves, it clicks, but I can't:
Scroll using the side
Scroll using multi touch, actually multitouch in general
I can't disable the touch pad at all, there is a key combination, FN+F3 which disables the touchpad in windows, but in ubuntu, all it does is make a notification pop up appear with touchpad symbol with a gray X on top. This does NOT disable the touchpad.
My biggest issue is that I can't disable tap-to-click.
This is really frustrating because the touch pad is very large and very easy to accidentially tap. This is the second time I've had to rewrite this because of that.

Here is some output to help:
$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Generic Mouse id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=15 [slave keyboard (3)]

I tried to implement this potential solution: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/550625/comments/307
but it didn't work.

I would appreciate any and all help you could give. If you need me to tell you anything more, let me know.

Question information

Have you tried Precise live CD, may help

I downloaded the daily build last night, burned it onto a cd, and booted up the laptop with it. Under System Settings -> Mouse and Touchpad, there is only one tab, Mouse. It still doesn't seem to recognize my touchpad as a touchpad. What do I do now?

Deimon (dm-vishnyakov) said : #3

Try to use script from http://ubuntuforums.org/showpost.php?p=11593780&postcount=33

Instruction how to use it:

you can paste script into gedit then save as mouse-on-off.sh (or whatever you prefer), these sort of scripts usually reside in ~/bin (home directory->bin directory), to use nautilus to change the permissions so you can run it, right click and check to box under the permissions tab or via command line chmod +x scriptname.sh.

then you can add a keyboard shortcut via the Keyboard->Shortcuts and select that script...

The script works, but it is like using a jackhammer to hang a picture on a wall. Yes, it disables the tap-to-click, however, it disables everything else with the touchpad as well. I believe that the core issue here is that Ubuntu fails to recognize the ALPS pad as a touchpad instead of as a mouse. While this solution does solve some aspects of the problem, I can't justify labeling the problem solved.

Can you help with this problem?

Provide an answer of your own, or ask Matthew Gilzinger for more information if necessary.

To post a message you must log in.