fn+f3 does not disable touchpad although transparent pop-up said it is disabled (Ubuntu 11.10 install on Dell Ispiron 17R laptop)

Asked by Martin C on 2011-12-03

I have a new installation of Ubuntu 11.10 on a Dell Inspiron 17r Laptop, and the
FN+F3 key combination does not work.

Expected: pressing Fn+f3 should disable the touchpad
Outcome: Although a transparent pop-up shows up on the top right hand corner
notifying user that the touchpad is disabled, the touchpad is still in operation.
Older distros had option under mouse/pointer device option disable touch pad
when typing, but this is not available with 11.10.
Fix: Making it operational Fn+F3, adding an option under mouse/pointing device to
disable touchpad when typing, allowing configuration of Fn+F? keys
Relates to: ALPS driver, Synaptics, xorg config???

I tried many things to fix this problem: Installing Synoptics, defining custom key
combinations... unsuccessful

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-input-synaptics Edit question
Assignee:
No assignee Edit question
Last query:
2011-12-03
Last reply:
2011-12-07

Are there any bugs reported?

Martin C (martincenek) said : #2

I did not see any.

I suggest you report one.

Ahmed Shams (ashams) said : #4

Does it auto-disable while typing and gets back after stop typing? if not, open terminal(Ctrl+Alt+T) and run:
syndaemon -i 0.5

in anyway, please try to disable it with this command:
gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled false
does this disable it? if it did, you can enable it back with:
gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

Martin C (martincenek) said : #5

Ahmed,

I tried everything possible:
syndaemon -i 0.5 executed just fine.

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled false
... this did not do anything. TouchPad works just fine, and it is not disabled even when I type (... and my chubby hands keep activating and clicking touchpad when I type). It might be because 11.10 distro does not have "/desktop/gnome/peripherals/touchpad/touchpad_enabled" and I don't know where else to find the device.

I did reinstalled xserver-xorg-input-synaptics package but it did not help, neither installing xserver-xorg-input-synaptics-dev package helped

I saw xserver-xorg-input-synaptics:i386 package, but the synaptic package manager was unable to install (dependencies etc).

This might be a clue: when I run
$ synclient -l
Couldn't find synaptics properties. No synaptics driver loaded?

obviouslly, some driver is loaded, since the trackpad works just fine, except disabling it is a problem (I could not find what command fn+f3 calls), so it is a mystery as for what package is used.

system-> preferemces->Mouse and trackpad (via Unity) in 11.10 distro does not even have the option of trackpad configuration.

here is the closest I got to the driver info:
$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ImPS/2 ALPS GlidePoint id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=13 [slave keyboard (3)]

Ahmed Shams (ashams) said : #6

Thanks Martin, it's a bug more than question. thanks for filing the report.

Can you help with this problem?

Provide an answer of your own, or ask Martin C for more information if necessary.

To post a message you must log in.