no touchpad tab

Asked by nebula on 2011-11-09

hi!
i'm using ubuntu 11.10 and there is no touchpad tab in system settings-->mouse and touchpad. i tried with gconf-editor from an old post but in /apps/gnome_settings_daemon/plugins there is only a pointing device file which is active. Still, there is no touchpad tab in system settings.. what can i do?? i need to disable touchpad while typing and this option is in this tab!

raavi (raavi) said : #1

What is the model of your laptop?

raavi (raavi) said : #2

You can try these :
sudo apt-get install kde-config-touchpad
or
sudo apt-get install touchpad-indicator

nebula (i-nebula) said : #3

it is a dell latitude E5420

i have installed the touchpad indicator but there is no option in it to disable touchpad only when typing.. i initially installed it because the shortcut (Fn+f5) for permanently(and not only while typing)disabling touchpad also doesn't work.. i thing the touchpad problem is general.. could i need any extra drivers? on windows 7 they all work..

raavi (raavi) said : #4

Then something interesting for you here :
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/760142

nebula (i-nebula) said : #6

i don't think i clearly understand.. they have made some scripts to turn on and off the touch pad, but the tab can't be displayed yet, huh? is there a chance that ubuntu fixes it with an update?

Try:

sudo modprobe -r psmouse; sleep 2; sudo modprobe psmouse

Does it work ok?

nebula (i-nebula) said : #10

what does sudo modprobe -r psmouse; sleep 2; sudo modprobe psmouse do?

nebula (i-nebula) said : #11

and who said the problem is answered??

I answered it. You are confusing answered with SOLVED which only you can assign. Solved means the issue is done and gone. So I say it is answered.

The command unloads and then reloads the module controlling the mouse, it can help

nebula (i-nebula) said : #13

ok, sorry for the misunderstanding! this command you gave me does deactivate and then activate the touchpad.And the application i have installed can do the same as well. does this mean that it is seen as a touchpad and not as i mouse?
is there a chance that they will be able to make the tab to be shown with an update, or only on the next version of ubuntu?

Well now you know which is coolio :)

Seems to be an issue. I've seen a few bugs around. Do you have the latest BIOS?

nebula (i-nebula) said : #15

hmmm.. i sincerely don't know. i didn't even know that there are several versions of bios.. :-p

Sure, there are updates which fix things. Its like a software, only special. There may be an update which has a fix to your issue.

nebula (i-nebula) said : #17

i typed sudo dmidecode -s bios-version in terminal and it says A01.. i have a dell latitude. do you think it needs update?

There is an A03

I jealous looking to the people for whom the patch from https://bugs.launchpad.net/ubuntu/+source/linux/+bug/760142/comments/78 works.

For my model Latitude E5420 touchpad support experimentally exists. But because tap click could not be disabled its a crap to work with the keyboard because the cursor moves on the slightest touch, really frustrating :(

Can you help with this problem?

Provide an answer of your own, or ask nebula for more information if necessary.

To post a message you must log in.