touchpad periodically freezes in Ubuntu 11.10

Asked by sally on 2011-10-26

The touchpad on my Dell 1420 Inspiron laptop has been periodically freezing since upgrading to Ubuntu 11.10. The mouse
works fine and after a restart, the touchpad works again. Thank you for any solutions to this problem.

Question information

Can you give the output of:

lsb_release -a; lsmod | grep mouse

Thanks

Mikal Meltvik (mikke654) said : #2

I've seen this alot in 11.10, but only on the first start after a fresh install.
From what I have seen the touchpad freezes up and does not respond until you reboot, after that it works like a charm.

It has happened to all the machines I have installed 11.10 to, or witnessed others installing it to.

Trevor Ritchie (tgritchie) said : #3

I have a similar problem on my Dell Inspiron. The relevant output in my case is as follows:

revor@trevor-laptop:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
trevor@trevor-laptop:~$ lsmod | grep mouse
psmouse 73673 0

Monitor_Inc (bobdharris) said : #4

Same problem on my Samsung M50.
Grep output identical to Trevor Ritchie.

http://ubuntuforums.org/archive/index.php/t-1616328.html

If you run:

sudo modprobe -r psmouse; sleep 2; sudo modprobe psmouse

Does it freeze again after the command

Monitor_Inc (bobdharris) said : #6

Ran actionparsnip sudo.
Didn't freeze until the next reboot.
Then it consistently freezes immediately after entering the keyring password prompt.
Got out of this by un-checking the "Disable touchpad whilst typing" box in touchpad properties.
I don't have a real mouse but ALT key combinations work when the touchpad is frozen.

ok then run:

gksudo gedit /etc/rc.local

and add the line:

modprobe -r psmouse; sleep 2; modprobe psmouse

add it ABOVE the exit 0 line, save the new file, close gedit and reboot

May help

Trevor Ritchie (tgritchie) said : #8

I ran the commands suggested by actionparsnip and the touchpad unfroze. AIUI this is simply removing and restarting the mouse kernel driver. While this is a handy work around I assume there is something that is causing the driver to stop responding in the first place. What is the best way to pursue this enquiry further?

Could report a bug. Does adding the command in rc.local help any?

Trevor Ritchie (tgritchie) said : #10

I did add the commands to rc.local but it seems that this runs only at power up/login. My touchpad freezes at any arbitrary time (and rarely at login) so rc.local modification won't do it for me. Looks more like a genuine bug to me :-(

Monitor_Inc (bobdharris) said : #11

I am content to leave this with the "Disable touchpad.........box" unchecked as a workaround.
However, if you would like me to do anything to help with your diagnostics, I will do it.

Many thanks for your help.

I have the same problem with my MacBook 4.1
The trouble periodically happens after I suspend my laptop. After my Macbook wakes up, often my touchpad freezes.
I nerver has this issue with Ubuntu 11.04. I have this problem since my upgrade to 11.10.

pklaus (pklaus) said : #13

I'm having the same issue on my Apple MacBook Pro 8.1 (early 2011) when running the Ubuntu 11.10 Live CD.

Dave L (westy3) said : #14

From reading different forums I see this problem seems to be affecting quite a few people. I can't find a bug for it though, is there one? The workaround seems to be to untick "disable touchpad while typing" - I suggest any reports that aren't fixed by this are a separate bug.

For me the problem occurs on Travelmate 5720 and is sporadic. It mainly occurs during use of Terminator - I suspect that is because that is the time when I am most heavily using the keyboard.

lsb_release -a; lsmod | grep mouse
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:cxx-4.0-amd64:cxx-4.0-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-3.2-amd64:printing-3.2-noarch:printing-4.0-amd64:printing-4.0-noarch:qt4-3.1-amd64:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
psmouse 73882 0

For the travelmate, try:

gksudo gedit /etc/modprobe.d/psmouse.conf

and add the line:

option psmouse.proto=imps

Then reboot to test

Dave L (westy3) said : #16

dave@westy3:/etc/modprobe.d$ cat psmouse.conf
option psmouse.proto=imps

(psmouse.conf is a new file)

Well it's certainly no worse with this setting - as to whether the freeze problem is fixed only time will tell, sometimes I don't see the issue for days or even weeks.

Dave L (westy3) said : #17

option psmouse.proto=imps does not fix it for the Travelmate.

Infact modprobe psmouse gives
WARNING: /etc/modprobe.d/psmouse.conf line 1: ignoring bad line starting with 'option'

It's worth noting that ctrl-alt-F1 can be used to get the command line in order to get control back if you loose the pointer and can't get to a terminal window easily. Then
sudo rmmod psmouse
sudo modprobe psmouse
Then ctrl-alt-F7 to get back to the desktop.

Ok my mistake, run:

gksudo gedit /etc/modprobe.d/psmouse.conf

and change:
option psmouse.proto=imps

to:
options psmouse.proto=imps

Save the new file, reboot to test

Dave L (westy3) said : #19

Same (ish) error

sudo vim psmouse.conf
[sudo] password for dave:
dave@westy3:/etc/modprobe.d$ sudo rmmod psmouse.conf
dave@westy3:/etc/modprobe.d$ sudo modprobe psmouse
WARNING: /etc/modprobe.d/psmouse.conf line 1: ignoring bad line starting with 'options'
dave@westy3:/etc/modprobe.d$ cat psmouse.conf
options psmouse.proto=imps

ok, run:

sudo rm /etc/modprobe.d/psmouse.conf
sudo modprobe -r psmouse
sudo modprobe psmouse

Is it ok?

Dave L (westy3) said : #21

Yes no error from that.

Mohamed Alaa (m-alaa8) said : #22

This command unfreezes the mouse:

synclient TouchpadOff=0

Mohamed Alaa (m-alaa8) said : #23

I've the same problem on my Acer Aspire One;
so, I've wrote a small Python script.

it may help:

#! /usr/bin/env python
import os
import gobject
def unfreeze():
    os.system('synclient TouchpadOff=0')
while 1:
    gobject.timeout_add_seconds(100,unfreeze)

add it to your startup programs

Mohamed Alaa (m-alaa8) said : #24

I'm sorry the previous code was wrong , thats works:
#! /usr/bin/env python
import os
import time
def unfreeze():
    print 'unfreeze'
    os.system('synclient TouchpadOff=0')
while True:
    time.sleep(600)
    unfreeze()

in addition to synclient, it seems

xinput <id of touchpad> set-prop "Synaptics Off" 0

also restores touchpad operation. it guess this is a bug of some sort with "syndaemon":
       syndaemon - a program that monitors keyboard activity and disables the
       touchpad when the keyboard is being used.

for some reason, my laptop had 2 syndaemons running while this problem occured (it has happened many times before but i hadn't checked). I'll instrument the syndaemon with some logging and see if i can get definite proof that it is causing the failure.

Simon741 (simon-okko) said : #27

Just installed Linux Mint 13 and this bug seems to still be unsolved...

How is trying mint going to do anything, the drivers are identical.... Try something like Suse or Mandriva.....

Can you help with this problem?

Provide an answer of your own, or ask sally for more information if necessary.

To post a message you must log in.