Enabling Logitech Click! Optical Mouse 4th button

Asked by Ol Rod on 2007-06-07

First time user. Kubuntu 7.0.4 64Bit AMD . Mouse is Logitech Click! optical, wired, PS/2 .Right click, Left Click,and Scroll Wheel all work perfect as they should. This mouse has a 4th button, When working properly is BACK command. 4th button does not work. When I press that button, I get box DO YOU WANT TO SEARCH THE INTERNET FOR UNKNOWN?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Solved by:
Cesare Tirabassi
Solved:
2007-06-11
Last query:
2007-06-11
Last reply:
2007-06-10
Cesare Tirabassi (norsetto) said : #1

Modify the relevant /etc/X11/xorg.conf InputDevice section file as follows:

Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "CorePointer"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ExplorerPS/2"
        Option "Buttons" "6"
        Option "ZAxisMapping" "4 5"
        Option "ButtonMapping" "1 2 3 6"
        Option "Emulate3Buttons" "false"
EndSection

Keep the original Driver and Device options.

This will make X11 recognise and pass the mouse button event, but it is up to every application to use this. Sometime it is by default (firefox), sometime it has to be configured, often it simply doesn't (konqueror).

Ol Rod (olrod) said : #2

Cesare: Thank You for responding. I regret that I am not technical enough for all this. By doing SEARCH, I found folder etc, and inside, a folder, X11, but it does not contain any xorg. I am not educated to write code, nor DOS. Maybe I am not ready for Linux. Thanks, again.

Markus Thielmann (thielmann) said : #3

We'll help you through that, Rod. It's not that technical as it looks.

1) Press the "F2" key. A small window will pop-up, titled "Run Application"and Option
2) Copy and paste the following command to this input field: gksudo gedit /etc/X11/xorg.conf
3) Wenn pressing "Run" you will be asked for your password. After you successfully provided it, a text editor appears.
4) The file might look wired, but it's quite structured. There are quite a lot of "Section [...] EndSection" Blocks. Just search for the Section "InputDevice".
5) After you found it, change it according to Cesares proposal. Be sure *not* to change the lines "Driver "mouse"" and "Option "Device" "/dev/input/mice"" or any other section of the file.
6) Save the text and close the editor, close all other work and restart the X-Server by pressing Ctrl-Alt-Backspace (*not* Ctrl-Alt-Del). If it's easier for you, just do a restart.

You're done after that.

Cesare Tirabassi (norsetto) said : #4

Ol Rod,

since you are using Kubuntu you should use: gksudo kate /etc/X11/xorg.conf as of point 2) of Markus instructions. Let us know if you run into difficulties.
A step at a time and you will be a linux guru in no time!

Ol Rod (olrod) said : #5

Thank you, Markus, and Cesare: I have tried to give fair effort. FIRST: I know I have several issues, and I hoped to sort them out one at a time, and I planned to post new quiry on each subject. I knew keyboard was not running all functions, so no surprise that F2 did nothing, I pressed F Lock, still Nothing!! I then went *Run Command*, typed in that *gsudo kate /etc/X11/xorg.config* . I checked run in terminal, provided password, Konsole displayed this* /bin/sh: gksudo: not found* . I went back, tried that third option, something about run real time, A Warning came up about DANGER, might lock up system, or be unstable, so I went no farther. I THINK I AM STUCK!!

Cesare Tirabassi (norsetto) said : #6

Don't worry, we will get you there.
Go again in Run Command, and in Options check "Run as a different user", give User name root and Password your password.
Then in Command "kate /etc/X11/xorg.conf" (without the ").
Once the file is open, go where it says:

Section "InputDevice"

and make the changes we told you. Save (5th icon from the right or ctrl-S or File->Save) exit and press Ctrl-Alt-Backspace (all together).

Now, if everything went ok, you will be able to use the 4th button in those applications that support it (like Firefox). Test it and let us know if it doesn't work.

Ol Rod (olrod) said : #7

These last instructions got me into the input Device file.Once again I run into Keyboard Problems. Writing those two new lines requires the quote key. THE QUOTE KEY DOES NOT WORK RIGHT! It is not hardware, I shut down computer, and exchanged keyboard to one that is nearly new. Both keyboards work properly in Windows. The problem here, when I press quote sometimes I get an accent mark that is not in my english,USA vocabulary. That mark is two dots above the next letter I type like this Ï Ä then this í á . I expect you know the issue. I had hoped to work this mouse issue to conclusion, and then make new post about keyboard.

Best Cesare Tirabassi (norsetto) said : #8

Hi Rod,

thats actually a feature, not a bug :)
If you need to use characters in use in other alphabets, like ä, õ, é etc., you can do that by pressing in sequence some keys (for instance " and a for ä).
You can simply skip this by pressing a space after the "special" character, for instance "<space> will produce ".
The special characters you will find in a generic 105-keys international keyboard are: " ' ~ ` ^

Once you have your mouse working the way you want it, close this ticket and open another one re. your keyboard. It is just a matter of choosing the right layout.
Please tell us in that if you have a generic keyboard (and how many keys) or a specific model, and what your locale is (I guess english-usa).

Ol Rod (olrod) said : #9

Success!! I made all those changes that Cesare proposed in his first post. It was some of a trick, since I still have this problem with the quote key, but the workaround works! Thanks Cesare, thanks Markus.