Mouse gets locked and irresponsive to left/right clicks

Asked by Ivo Ivanov on 2013-11-03

I am using Ubuntu 12.04.3 LTS and the apt-cache says:
---
xserver-xorg-input-mouse:
  Installed: 1:1.7.1-1build3
  Candidate: 1:1.7.1-1build3
  Version table:
 *** 1:1.7.1-1build3 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
---

I am experiencing a very odd problem with the mouse pointer. Whenever I start a new application the mouse pointer gets locked and no clicks inside the application are processed. The mouse moves on the screen, though. The only way to unlock the mouse clicking is to select anything in the main menu (on the panel) and then a right click in the application itself. Sometimes several clicks here and there are needed to make the mouse work properly. While the mouse is lock the application switcher is not working either; pressing ALT+TAB does nothing. When a modal dialog pops up then there is no way to unlock the mouse, but to close the window.
This started happening since about a month ago when I installed some updates, so I am not sure exactly which package is broken. I think it is the xserver-xorg-input-mouse, but am not sure. I installed Ubuntu Studio 13.10 on my system and the problem is in there, too. Tried the latest version of another Ubuntu based distro and it has the same problem. With Ubuntu Studio the problem is very frustrated, because the mouse is unusable during the installation.
In gnome-terminal I noticed that when the application is started the main menu in the top panel stays active.

Can someone help me with overcoming this problem? I am willing to contribute to troubleshooting and solving some of my time as well.

TIA,

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Solved by:
Ivo Ivanov
Solved:
2013-11-07
Last query:
2013-11-07
Last reply:
2013-11-03

This question was reopened

What desktop / session are you using? If you are using Unity shell, have you tried Unity 2D?

Thanks

Ivo Ivanov (iyivanov) said : #2

Yes, I am using Unity. I have Logitech wireless keyboard+mouse.
How do I switch to Unity 2D?

TIA,
Ivo

Log off and click the icon near your username, the log in.

Ivo Ivanov (iyivanov) said : #4

Just did switch to Unity 2D. Seems to be solved.
Wonder now why the 3D is broken. Maybe the occasional flickering I see is because the system is switching 3D-2D by itself (or at least trying to)?!?

Thanks,
Ivo

Ivo Ivanov (iyivanov) said : #5

Thanks actionparsnip, that solved my question.

Ivo Ivanov (iyivanov) said : #6

Whoops, seems like the problem is coming back.
After a couple of hours working in Unity-2D the problem occurred again.

In Ubuntu Studio, using XFCE, after pressing CTRL+ALT+DEL I saw an error message something like "screensaver error: cannot grab the mouse pointer, already grabbed".

Any idea?

TIA,

Ivo Ivanov (iyivanov) said : #7

Yipiii! My problems is solved. It turned out to be a hardware problem. My mouse was broken and xorg was going mad. I replaced it, but really removed it, disconnected it. I had tried before that another mouse, but both connected at the same time. Now with the new mouse everything is OK.