lenovo trackpad and mouse clicks failing on ubuntu 12 and ubuntu hangs and crashes

Asked by Sagar on 2012-10-27

i just installed the latest desktop edition of ubuntu, but the mouse click on trackpad and the trackpad itself doesn't seem to work properly ... ubuntu crashes up, it hangs up i have to restart the session again.

i have configured the keyboard and mouse settings properly, does anyone know what i am missing here ?

i thought ubuntu never crashed /// but it seems other way round here

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-28
Last reply:
2012-10-28

What model lenovo do you have?

What is the output of:

lsb_release -a; uname -a

Thanks

Sagar (sagar-thakar) said : #3

laptop lenovo model is 3000 N100

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal

Sagar (sagar-thakar) said : #4

i am very surprised to see Ubuntu crashing and hanging like windows ....even if i close the laptop lid and reopen it, Ubuntu hangs up and it becomes unresponsive...

don't know what is happening, long back i had this 8 and 10 version which were good and fast ...i am doubtful about this 12.10 release it doesnt look fast, seems problem with multi-tasking as well.

You have a VERY young release, as it matures it will improve.

Seems that tap-clicking and dragging needs to be enabled in System Preferences

Source:
http://wiki.osx86project.org/wiki/index.php/HCL_10.4.8/Portables#Lenovo_3000_V100

Sagar (sagar-thakar) said : #6

andrew, i hope you are right ... i have already enabled the tap clicking and dragging as suggested by you.

what do you think should i keep the same version for now or revert it to a earlier version? if i shud revert to a earlier version according to you which version shud i get installed.

please advise

thanks

sagar

Try the boot option:

i8024.nopnp

Works on most Sony Vaios. May work for you.

Sagar (sagar-thakar) said : #8

is this command which i have to use in terminal ?

No it's an option you apply to grub, it makes the kernel act differently and may help. These options are set at boot, hence it being called a 'boot option'

Sagar (sagar-thakar) said : #10

andrew, i am new to linux, could you help me how to do this ?

thanks for al lthe help

Yes but not new to using the web and finding out. I'm sure you've done that a fair bit......

run:
gksudo gedit /etc/default/grub

find this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change it to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8024.nopnp"

Save the new file and run:
sudo update-grub

Then reboot to test

Can you help with this problem?

Provide an answer of your own, or ask Sagar for more information if necessary.

To post a message you must log in.