How to enable a usb joystick as an alternative to the mouse?

Asked by Marja Erwin on 2012-07-20

I'm borrowing a usb joystick because of arm injuries. I just want to be able to use the computer for basic tasks [email, writing, etc.] while my arms heal, and using the keyboard and mouse requires painful arm-twists. I'm using Gnome 2/Classic in Ubuntu 11.04.

Right now the joystick shows up in ls /dev/input but cannot move the cursor and does not show up in the mouse preferences or anywhere else I've looked. I have searched for instructions to enable the joystick, but none of them have worked.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Solved by:
Marja Erwin
Solved:
2012-07-21
Last query:
2012-07-21
Last reply:
2012-07-20

Seems there is a package called js2mouse you may be able to use

Marja Erwin (marja-e) said : #2

It's not in the software center or sourceforge. I found a version here:

http://cedric.vincent.perso.free.fr/Projets/index.html

but the installation instructions failed:

tar (child): js2mouse-040208.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now

http://www.playdeb.net/updates/ubuntu/12.04/?q=joy

May help. If you run:

wget http://archive.getdeb.net/install_deb/playdeb_0.3-1~getdeb1_all.deb
sudo dpkg -i ./playdeb_0.3-1~getdeb1_all.deb
rm ./playdeb_0.3-1~getdeb1_all.deb
sudo apt-get update

You can use the links in the web page. May help some

Marja Erwin (marja-e) said : #4

I tried installing playdeb as a source. It didn't work. I think playdeb may not support 11.04 any more, it keeps insisting on 12.04.

I found the tarball on sourceforge, and a friend of mine helped install the tarball and some libraries it required, but qjoypad isn't working.

Marja Erwin (marja-e) said : #5

Okay, correction there, qjoypad is working.

Right now ls /dev/input shows that the computer detects the joystick. [js0] cat /dev/input/js0 shows that it can receive signals from the joystick. qjoypad shows up on the top panel, and is now detecting the joystick, but when updating the layout list it can detect no signals from the joystick. so something has gone wrong in between. I tried to install the joystick drivers earlier, but that may not have worked.

Marja Erwin (marja-e) said : #6

Now everything's working. I did this slightly out-of-order but thing the following steps should work:

1. plug in the joystick.

2. look for it under ls /dev/input [in terminal] it should probably appear as js0 or something similar.

3. check if it's signalling anything using cat /dev/input/js0 [in terminal] it should produce gibberish as you move the joystick.

4. install joystick [which replaces jscalibrator] from the software center, and find and install qjoypad, this may take some doing from the tarball. you may want to bookmark the qjoypad documtation:

http://qjoypad.sourceforge.net/doc/doc_index.html

5. install the xorg joystick drivers from the software center, and find and install the appropriate drivers from here too [I'm not sure both sets of drivers are necessary, but I couldn't get it to work until installing both sets and restarting]:

http://ubuntuforums.org/showthread.php?t=330607&highlight=joystick+interact

if you have a usb joystick, you can skip the references to gameports and gameport drivers, and you can skip one line in the modules list edit.

6. restart, or wait until you've restarted.

7. run jscal [in terminal] to calibrate the joystick. I think the code is jscal /dev/input/js0 -c [in terminal] it should prompt you to move the joystick in various directions.

8. run qjoypad [in terminal or by looking in usr/local/bin - not in your personal directory] to start qjoypad. click on the top or bottom panel to open the settings. name your joystick, and start messing about with the settings. save once you've established ones that work for you.

9. Okay, it should be good to go!