Uncontrollable mouse pointer when resizing windows

Asked by Peter T Hayward on 2012-06-05

Using quantal, up to date on 4 June 2012.
System is a iMac 11,2 (mid 2010) with i3 processor, 4 GB memory and Mobility Radeon 4670 video.
Currently booted into gnome desktop (Ubuntu 12.10 (quantal) using efi stub boot on 3.4.0-3 kernel (first time I've been able to do this). Other ways of booting have been tried but don't change this problem.
The graphics driver in use is uncertain. I couldn't get fglrx to compile against this kernel so I set the xorg device to 'fbdev'.
Windows move easily on screen and there doesn't seem to be any lag in redraws. I'd say the desktop is as responsive as OSX.

When I want to resize a window, by click-drag the bottom right corner of the window, the mouse pointer jumps around and is almost impossible to control. The same occurs on the right hand edge of a window. The mouse pointer is better, but not good compared with OSX pointer handling, on the left hand edge of the window.
I have tried to disable overlay scrollbars using
sudo echo "export LIBOVERLAY_SCROLLBAR=0" > /etc/X11/Xsession.d/80overlayscrollbars
and rebooting. There is a marginal improvement from this.

This lack of pointer control was present on 12.04 but didn't seem so severe as it is now.
I regard this as a major fault in usability for the desktop.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-05
Last reply:
2012-06-05

sudo echo "export LIBOVERLAY_SCROLLBAR=0" > /etc/X11/Xsession.d/80overlayscrollbars

Won't work, the sudo doesn't traverse the redirection, you will need to run:

echo "export LIBOVERLAY_SCROLLBAR=0" | sudo tee /etc/X11/Xsession.d/80overlayscrollbars

I suggest you report a bug, Quantal isn't even in Alpha1 yet so you WILL see a tonne of bugs.

Can you help with this problem?

Provide an answer of your own, or ask Peter T Hayward for more information if necessary.

To post a message you must log in.