mouse cursor in desktop is a blank white square - how change?

Asked by Richard Scrase on 2011-11-29

Just upgraded to oneiric ocelot. All seems to work fine except the mouse cursor on the desktop, which is just a blank white square a little larger than a normal cursor image. Most applications show their usual mouse cursor within the working area of their window, but only the blank white square when the cursor is moved on to the window title bar. I cannot find a method of changing the desktop cursor and assume it is tied to the selected theme: all the themes tried showed this behaviour.

It's possible to use the system by pointing the top left hand corner of the blank white square cursor at the object being clicked - but it feels a bit odd!

Anyone seen this before?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-30
Last reply:
2011-11-30

Does it happen as a new user?

Thank you for the response, Andrew. Just setting up a single new user account restores the normal arrow cursor for all users while the machine is running. After a machine restart, however, all users (including the new account) once again have the blank white square mouse cursor on the desktop.

Sam_ (and-sam) said : #3

Try this:
sudo update-alternatives --config x-cursor-theme

and restart xserver (logout-in).

Thank you for the response, Sam. The first time I tried this, I selected the default from the six options offered and the cursor appearance was unchanged after logging out and in. The second time, I selected option 6, which looked as though it's the same as the default, and, after logging out, the normal desktop cursor was restored. On restarting the machine, however, the blank white square mouse cursor returned and remains after login. BUT NOW if I log out again the proper desktop cursor returns for all users. I think this is probably new behaviour as a result of the update but I can't now be sure of the mix between restarts and logouts that I used to switch between users when I was checking out Andrew's query above.

Summarising, the current behaviour is:
on startup: blank white square cursor
after login: blank white square cursor
after logout: normal arrow cursor
after new login: normal arrow cursor

I've got two machines here running Ubuntu 11.10 64 bit AMD (both upgraded within a few weeks of each other) and only one is showing this cursor problem. I would like to check for different versions of the relevant files on the two installations but I have no idea where to start looking: any suggestions?

Can you help with this problem?

Provide an answer of your own, or ask Richard Scrase for more information if necessary.

To post a message you must log in.