Pentium D system with 11.04: Mouse buttons fail after 10min

Asked by LEGOManiac on 2011-11-27

The mouse buttons on this system stop working every 10-15 minutes or so. The pointer still moves and the keyboard still works (HP wireless keyboard+mouse combo) but neither of the mouse buttons continue to click.

It just occurs to me that I can run wireshark to monitor the USB port to see if the button clicks are actually being received.

Does anyone have any ideas about what to do about this? Currently, the only thing that re-enables it is to open a terminal and issue a shutdown -r now command.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Solved by:
LEGOManiac
Solved:
2011-12-01
Last query:
2011-12-01
Last reply:
2011-11-27
mycae (mycae) said : #1

as a quick test, does rmmod and modprob -ing any particular modules (say uhci_hcd and ehci_hcd or usbcore) also "fix" the device when this occurs?

LEGOManiac (bzflaglegomaniac) said : #2

In this latest failure, only the left mouse button stopped working. I could still get the context menu.

I again confirmed via wireshark (started via SSH from another PC) that the left mouse button event is being received.

I noted that after switching to a local terminal and back to the X display, the top an bottom menu bars blank and grey, instead of the default black with text.

rmmod uhci_hcd or ehci_hcd or usbcore did nothing. Listing /proc/modules shows that none of these exist.

I did find usbhid, which I removed, and had the predictable effect of killing both the mouse and keyboard.

I'm really not sure what other module would apply. Also, I couldn't figure out (via ssh) how to use modprobe. man modprobe is not all that clearly written for the inexperienced. :-)

Removing the wireless mouse adapter caused the module to be re-installed but did not restore the operation of the mouse button. I wound up rebooting.

I did note that, while I was in the terminal session, I was getting notices of the processor overheating and the clock being scaled back. It's probably coincidental, but I thought I'd point it out. Have to go check the heat sink....

mycae (mycae) said : #3

If you rmmod the usbhid, then do it like so:

rmmod usbhid && modprobe usbhid

that way you wont lose your keyboard. If this fixes the mouse, then it is clearly a software problem - if not, then it could be a hardware issue.

LEGOManiac (bzflaglegomaniac) said : #4

We have two identical keyboard/mouse sets. I just swapped them so we'll see if the problem persists at my computer now.

I can't see it being a hardware problem, though, since Wireshark sees the USB events when the mouse buttons are pressed.

I just noticed something: the old wireless mouse receiver was still plugged into the PS2 ports even though the keyboard and mouse for it are gone (forgot to remove it), so I'll let it go for a while and see if that had anything to do with it.

LEGOManiac (bzflaglegomaniac) said : #5

The problem was resolved by unplugging the second keyboard and mouse reciever.