Mouse intermittently locking up

Asked by Mannex on 2011-10-17

My mouse seems to intermittently lock up on 10.11. I have no idea what's causing it. The OS is still responsive to keyboard, and everything else seems to be running. A manual logout (with the 3-finger salute) seems to reset it. I can go hours sometimes with no problem, and other times it happens within a minute of login.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-18
Last reply:
2011-10-18

When it unfreezes, run:

dmesg | tail -n 10; lsb_release -a

What is output

Thanks

Mannex (russ-mannex) said : #2

When you say "unfreezes" I assume you mean after I log out and in again, since that seems to be the only way to unfreeze it. I'm afraid the last ten entries aren't going to be much help. Sorry.

mannex@leviathan:~$ dmesg | tail -n 10; lsb_release -a
[32626.895717] Inbound IN=wlan1 OUT= MAC=00:0e:3b:0d:42:3e:00:22:3f:26:9a:e5:08:00 SRC=203.109.221.2 DST=192.168.1.3 LEN=48 TOS=0x00 PREC=0x00 TTL=113 ID=6224 PROTO=UDP SPT=10002 DPT=55017 LEN=28
[32627.045326] Inbound IN=wlan1 OUT= MAC=00:0e:3b:0d:42:3e:00:22:3f:26:9a:e5:08:00 SRC=97.97.162.218 DST=192.168.1.3 LEN=48 TOS=0x00 PREC=0x00 TTL=109 ID=17168 DF PROTO=TCP SPT=61241 DPT=55017 WINDOW=8192 RES=0x00 SYN URGP=0
[32627.225657] Inbound IN=wlan1 OUT= MAC=00:0e:3b:0d:42:3e:00:22:3f:26:9a:e5:08:00 SRC=58.142.25.206 DST=192.168.1.3 LEN=48 TOS=0x00 PREC=0x00 TTL=112 ID=4421 PROTO=UDP SPT=65275 DPT=55017 LEN=28
[32627.430937] Inbound IN=wlan1 OUT= MAC=00:0e:3b:0d:42:3e:00:22:3f:26:9a:e5:08:00 SRC=92.11.203.195 DST=192.168.1.3 LEN=48 TOS=0x00 PREC=0x00 TTL=105 ID=31221 PROTO=UDP SPT=24449 DPT=55017 LEN=28
[32627.481375] Inbound IN=wlan1 OUT= MAC=00:0e:3b:0d:42:3e:00:22:3f:26:9a:e5:08:00 SRC=79.110.198.254 DST=192.168.1.3 LEN=58 TOS=0x00 PREC=0x00 TTL=109 ID=33956 PROTO=UDP SPT=50884 DPT=55017 LEN=38
[32627.581151] Inbound IN=wlan1 OUT= MAC=00:0e:3b:0d:42:3e:00:22:3f:26:9a:e5:08:00 SRC=65.96.183.2 DST=192.168.1.3 LEN=58 TOS=0x00 PREC=0x00 TTL=111 ID=17474 PROTO=UDP SPT=55078 DPT=55017 LEN=38
[32627.858300] Inbound IN=wlan1 OUT= MAC=00:0e:3b:0d:42:3e:00:22:3f:26:9a:e5:08:00 SRC=59.99.160.35 DST=192.168.1.3 LEN=60 TOS=0x00 PREC=0x00 TTL=43 ID=58799 DF PROTO=TCP SPT=48424 DPT=55017 WINDOW=5840 RES=0x00 SYN URGP=0
[32628.673838] Inbound IN=wlan1 OUT= MAC=00:0e:3b:0d:42:3e:00:22:3f:26:9a:e5:08:00 SRC=70.74.235.166 DST=192.168.1.3 LEN=48 TOS=0x00 PREC=0x00 TTL=115 ID=1019 PROTO=UDP SPT=64014 DPT=55017 LEN=28
[32628.796253] Inbound IN=wlan1 OUT= MAC=00:0e:3b:0d:42:3e:00:22:3f:26:9a:e5:08:00 SRC=66.233.50.202 DST=192.168.1.3 LEN=48 TOS=0x00 PREC=0x00 TTL=112 ID=16953 DF PROTO=TCP SPT=59307 DPT=55017 WINDOW=8192 RES=0x00 SYN URGP=0
[32629.090182] Inbound IN=wlan1 OUT= MAC=00:0e:3b:0d:42:3e:00:22:3f:26:9a:e5:08:00 SRC=110.175.143.201 DST=192.168.1.3 LEN=58 TOS=0x00 PREC=0x00 TTL=112 ID=68 PROTO=UDP SPT=29044 DPT=55017 LEN=38
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
mannex@leviathan:~$

The next time this happens, I can ctrl-alt-F1 and try it from there, if you like. That might give slightly more recent info. Let me know.

Is logging in and out the only way to ounfreeze it that you know of?

Mannex (russ-mannex) said : #4

Yes, it is the only way I know of. If you have any suggestions for another way, I'd be very grateful (and would consider that a workaround!).

Can you press CTRL+ALT+F1 and run:

sudo modprobe -r psmouse; sleep 2; sudo modprobe psmouse

Then press CTRL+ALT+F7 to get back to the desktop?

Mannex (russ-mannex) said : #6

Since I'll never remember that (old age sucks!), I put it in a little shell script. The next time it happens, I'll run it and see.

As a note of possible interest here, there's a setting to disable the mousepad whenever I'm typing (I'm using a machine with a touchpad). I turned the disabling off, and the problem hasn't yet remanifested. Let me know if you want me to turn it back on to test whether reloading the module fixes it. Thanks.

Can you help with this problem?

Provide an answer of your own, or ask Mannex for more information if necessary.

To post a message you must log in.