Logitech g300 mouse jumping around

Asked by therelic on 2011-09-29

Got the new Logitech g300 mouse. Works fine in windows. Has a problem in Kubuntu and Ubuntu. I think the primary problem is that it is so new that nothing recognizes it.

The mouse jumps around the screen, normally when you press a button it will center itself on the left side half way down. Very difficult to click anything. It is multi-button so I am not 100% sure what way to set it up.

I am wondering if the stats and information have been set up in 11.10 yet.

If not I could try to provide information for making it work properly. It is an unrecognized mouse by current packages/programs I have tried like lomoco.

Not sure if it should be a bug report or directed more to some other dev. Any advice would be helpful.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Last query:
2011-09-29
Last reply:
2011-10-02

Can you give the output of:

lsmod; lsb_release -a; uname -a

Thanks

therelic (the-one-relic) said : #2

I am on Kubuntu at this time of the day and it was a fight to get this with only the g300 plugged in. I tried getting it from the 11.04 boot/install cd I had handy but the mouse didn't want to cooperate much on that either. Also I added the mouse information below.

relic@Artifact:~$ lsmod
Module Size Used by
dm_crypt 22993 0
vesafb 13761 1
nvidia 10709116 30
snd_hda_codec_realtek 336771 1
snd_hda_intel 33176 2
snd_hda_codec 103804 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13604 1 snd_hda_codec
snd_pcm 96391 2 snd_hda_intel,snd_hda_codec
ipt_REJECT 12576 1
ppdev 17113 0
ipt_LOG 17016 5
snd_seq_midi 13324 0
xt_limit 12711 7
snd_rawmidi 30486 1 snd_seq_midi
xt_tcpudp 12603 8
ipt_addrtype 12599 4
xt_state 12578 7
snd_seq_midi_event 14899 1 snd_seq_midi
iptable_nat 13182 0
snd_seq 61621 2 snd_seq_midi,snd_seq_midi_event
iptable_mangle 12734 0
snd_timer 29602 2 snd_pcm,snd_seq
snd_seq_device 14462 3 snd_seq_midi,snd_rawmidi,snd_seq
joydev 17606 0
snd 67382 13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
ip6table_filter 12815 1
ip6_tables 27845 1 ip6table_filter
nf_nat_irc 12643 0
nf_conntrack_irc 13383 1 nf_nat_irc
nf_nat_ftp 12649 0
nf_nat 25736 3 iptable_nat,nf_nat_irc,nf_nat_ftp
nf_conntrack_ipv4 19640 10 iptable_nat,nf_nat
nf_defrag_ipv4 12729 1 nf_conntrack_ipv4
parport_pc 36959 1
nf_conntrack_ftp 13359 1 nf_nat_ftp
nf_conntrack 81956 8 xt_state,iptable_nat,nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_nat,nf_conntrack_ipv4,nf_conntrack_ftp
iptable_filter 12810 1
ip_tables 27456 3 iptable_nat,iptable_mangle,iptable_filter
x_tables 29581 12 ipt_REJECT,ipt_LOG,xt_limit,xt_tcpudp,ipt_addrtype,xt_state,iptable_nat,iptable_mangle,ip6table_filter,ip6_tables,iptable_filter,ip_tables
soundcore 12680 1 snd
snd_page_alloc 18529 2 snd_hda_intel,snd_pcm
coretemp 13490 0
it87 43379 0
hwmon_vid 12746 1 it87
max6650 14324 0
lp 17825 0
parport 46458 3 ppdev,parport_pc,lp
usbhid 46956 0
hid 91020 1 usbhid
floppy 74120 0
pata_jmicron 12747 0
r8169 48022 0

relic@Artifact:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

relic@Artifact:~$ uname -a
Linux Artifact 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:17:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Also grabbed this when it was plugged in once...

Bus 006 Device 002: ID 046d:c246 Logitech, Inc.
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 8
  idVendor 0x046d Logitech, Inc.
  idProduct 0xc246
  bcdDevice 70.02
  iManufacturer 1
  iProduct 2
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 59
    bNumInterfaces 2
    bConfigurationValue 1
    iConfiguration 4
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 200mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 3 Human Interface Device
      bInterfaceSubClass 1 Boot Interface Subclass
      bInterfaceProtocol 2 Mouse
      iInterface 0
        HID Device Descriptor:
          bLength 9
          bDescriptorType 33
          bcdHID 1.10
          bCountryCode 0 Not supported
          bNumDescriptors 1
          bDescriptorType 34 Report
          wDescriptorLength 58
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0007 1x 7 bytes
        bInterval 1
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 1
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 3 Human Interface Device
      bInterfaceSubClass 0 No Subclass
      bInterfaceProtocol 1 Keyboard
      iInterface 0
        HID Device Descriptor:
          bLength 9
          bDescriptorType 33
          bcdHID 1.10
          bCountryCode 0 Not supported
          bNumDescriptors 1
          bDescriptorType 34 Report
          wDescriptorLength 107
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x82 EP 2 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0007 1x 7 bytes
        bInterval 1
can't get device qualifier: Operation not permitted
can't get debug descriptor: Operation not permitted
cannot read device status, Operation not permitted (1)

I: Bus=0003 Vendor=046d Product=c246 Version=0110
N: Name="Logitech Gaming Mouse G300"
P: Phys=usb-0000:00:1d.0-2/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb6/6-2/6-2:1.0/input/input4
U: Uniq=
H: Handlers=mouse1 event4
B: PROP=0
B: EV=17
B: KEY=ffff0000 0 0 0 0
B: REL=103
B: MSC=10

I: Bus=0003 Vendor=046d Product=c246 Version=0110
N: Name="Logitech Gaming Mouse G300"
P: Phys=usb-0000:00:1d.0-2/input1
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb6/6-2/6-2:1.1/input/input5
U: Uniq=
H: Handlers=sysrq kbd event5
B: PROP=0
B: EV=10001b
B: KEY=1000000000007 ff800000000007ff febeffdfffefffff fffffffffffffffe
B: ABS=f0000000000
B: MSC=10

Logitech hate Linux and flat refuse to support the OS. I suggest against buying these devices.

May help:
http://askubuntu.com/questions/63283/logitech-g300-not-working-on-ubuntu

I have the same problem, and also saw that link on askubuntu.com. Lomoco doesnt recognize the G300 either. Posted on their mailing list already, but I guess they're not that active.

I really don't know where to start fixing this... Anything else I can do or check besides mailing on Lomoco list?

Tomáš Myšík (gapon) said : #5

Same problem here... :/

I did find the cause of the problem, and a temporary solution:

http://ubuntuforums.org/showthread.php?t=1849041&highlight=g300

Can you help with this problem?

Provide an answer of your own, or ask therelic for more information if necessary.

To post a message you must log in.