Ubuntu 11.04 slow to respond to mouse click grab

Asked by Edward J Shapard on 2011-09-09

After upgrading to 11.04 from 9.10, and using 'ubuntu classic' for the gnome interface, windows have an annoying delay when I try to drag them.

If I click on a window titlebar, it takes about one second before the pointer turns into a hand and I can drag the window. I never had this problem before. In the past, I could just drag immediately after clicking. Similar issues with highlighting and dragging scroll bars.

Tried messing around with mouse settings in System - Preferences, but no luck.

How can I get rid of this annoying delay?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Solved by:
Edward J Shapard
Solved:
2011-09-13
Last query:
2011-09-13
Last reply:
2011-09-09

Did you upgrade directly from Karmic to Natty?

Edward J Shapard (ed-shapard) said : #2

I upgraded through all releases in between using the upgrade utility. When I had other problems, I upgraded using the the 11.04 cd.

Edward J Shapard (ed-shapard) said : #3

I found information at http://ubuntuforums.org/showthread.php?t=1636068

looks like the same issue in 10.04 being caused by middle mouse button emulation.

I had used gpointing-device-settings (I think that's the name of it. not at that machine right now) to enable middle button emulation. Apparently, there's a timeout for this setting. I'll try reducing the timeout and see if that fixes the issue.

Wish 11.04 had come with 3 button emulation out-of-the-box like previous Ubuntus had.

Edward J Shapard (ed-shapard) said : #4

It was the timeout setting for 3 button emulation in gpointing-device-settings. Shortening the timeout fixed the issue right away.