Mouse / keyboard / window focus problem suddenly started in 11.04 on Thinkpad W510

Asked by Paul Chorley on 2011-08-17

I have been using Ubuntu 11.04 on my Lenovo Thinkpad W510 for a few weeks and after getting the graphics to work properly (disabling NVidia Optimus in the BIOS sorted that out) things were pretty good. Occasional glitches with the UI, but otherwise fine.

Then, two days ago, while watching a Sky News clip on Youtube, I suddenly found that mouse clicks were not working. Turns out this was not the only thing wrong.

After several reboots and having tried the fall back Gnome interface (i.e. not Unity) my problems have persisted.

Here are the symptoms, which are not restricted to any particular session (I have problems at the login screen too). N.b. these are all intermittent, in that that things sometimes work. Most of the time however I get all the following problems and the OS is therefore currently unusable. :(

1. Window focus doesn't appear to follow the mouse pointer properly. Worse when some window is Maximised. Focus appears to get 'stuck' in one place.

2. Mouse clicks don't always work. This appears to be interacting with problem 1, but also just does weird things. E.g. the Thinkpad W510 has two sets of mouse keys, but only one of the right-click buttons seems to work, the other one seems dead (most of the time).

3. Alt-Tab doesn't do anything, even though both Alt and Tab keys are fine.

4. Various other random and difficult to pinpoint input and window focus related errors. Best summarised as failure to respond to commands, rather than doing something unexpected.

Any ideas ... before I switch to a different distro?

Thanks,
Paul.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Solved by:
Paul Chorley
Solved:
2011-08-18
Last query:
2011-08-18
Last reply:
2011-08-17
Chris (fabricator4) said : #1

Have you done much configuration in Unity, such as installing Compiz Manager and playing with the settings? It seems to be possible to really confuse Unity, since it actually wasn't designed to be tweaked, or at least not at this stage. Try setting Unity back to all defaults: In a terminal type -

Unity --reset

Chris

Paul Chorley (paulch) said : #2

Thanks Chris.

Unfortunately (as I mentioned) I have the same problem in the fall back GNOME interface. This is not a problem with Unity. Moreover, I tried booting Ubuntu from the install CD last night and found he same issue.

If I do not touch the trackpad after rebooting (or if I disable it in the BIOS) then both the built in Intelipoint thingy and an external mouse work perfectly. So ...

 I think it is hardware, with something on the track pad failing after first use.

I will close this bug and contact Lenovo.

Thanks again for your help.

michael sumrall (sumrall-mp) said : #3

I am having the same issue on a Lenovo Thinkpad.

Ubuntu originally worked fine. Now, I am all but unable to focus on the desired window.

I just wiped my computer and started over with a clean install. All settings are default. The problems persists.

Specifics:

I intially have focus on the desktop and can open windows and applications normally.

I obtain focus on the home folder and the icons within normally, and have no problems exiting this window.

I open other windows, such as Firefox, and I do not obtain focus.

With Firefox open, I open the home folder. From the home file I select file -> close all windows.

I now have focus on Firefoxt and my can click on links normally. I have, however, lost focus on the desktop. I am unable to open other applications or close Firefox. My only option to exit is using the power button to bring up the power options window, tabbing to the reboot option, and hitting the enter key. The touchpad curser maintains focus on Firefox.