PS2 mouse

Asked by David_g on 2011-07-31

I am using Ubuntu 11.04 on an Asus mother board M4A77T, using a USB PS2 adapter both mouse and keyboard work, although the mouse is erratic, mouse pointer jumps around the screen and brings up boxes that you would normally right click for.

Both my original mouse, an old mouse and a new mouse all act the same.

I have tried to use the PS2 port on the motherboard which is described as a 'keyboard/mouse combo port'. Asus technical support have not been able to help with PS2 pinouts for this board.

The PS2 keyboard works fine, but I cannot get a PS2 mouse to work, there's power to the mouse as the leds on the underside are on. From details found on the net I've made a cable that should allow me to connect both a keyboard and a mouse to the combo port. With or without my cable the mouse will not work.

I need to use PS2 to connect to my keyboard/mouse/video switch.

Can anybody help me with the erratic mouse or the combo PS2 port?

Thank you,

David.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Solved by:
David_g
Solved:
2011-08-14
Last query:
2011-08-14
Last reply:
Joseph (joehms22) said : #1

Many of these "combo ports" only support one at a time, either a mouse or a keyboard.

My suggestion would be to hack a USB to PS/2 from your computer to KVM, then a PS/2 to USB for attaching a USB keyboard; or if it is a two terminal KVM, just get a new one, the cheap ones are going for around $20USD on amazon with USB support.

General question, does your mouse move while typing?

David_g (david-g-jones) said : #2

Dear Joseph,

Thank you for the reply.

The combo port only works with a keyboard, plugging a mouse in has no effect, I wonder if this motherboard has a more fundamental problem?

I bought a PS2 splitter today, it works as well as the one I constructed..........

I'll look into the USB KVM, the one I'm using at present is a 2 port PS2.

About the general question, I can be typing and suddenly I am typing into free space, the mouse problem has diverted the keyboard input to somewhere else, where I don't know.

David.

Joseph (joehms22) said : #3

Hey David,

No problem.

That is really strange, I wonder if the Kernel is only recognizing it as a keyboard port rather than a mouse or keyboard?
You could attempt unloading and reloading the PS/2 mouse kernel module by running:

sudo modprobe -r psmouse
sudo modprobe psmouse

Note that between those commands your mouse will disappear. First, however, I would check if the PS/2 mouse module is actually loaded by running:

lsmod | grep psmouse

No output means no mouse support.

Hopefully you kept the receipt :)

If you are using Ubuntu Classic (chosen by a dropdown at the bottom of your login screen) you could try adding a widget to the panel at the top by right clicking it and choosing "Add to panel", then find and drag the "Pointer Capture Applet" up there. Once clicked, it will lock the mouse pointer up there, and allow you to continue entering text, that way your pointer won't focus on anything else (hopefully).

Good Luck,
   Joseph

David_g (david-g-jones) said : #4

Dear Joseph,

Sorry for the delay in getting back to you.

I tried what you said, no difference.

Now I've bought a USB KVM and the problems 'gone away'.

I suspect the problem was with the motherboard, I asked questions from Asus technical support and they tried to side step the issue, so I gave up.

I bought this particular motherboard to solve another issue, hot swap for SATA drives, which it does very nicely.

regards,

David.

David_g (david-g-jones) said : #5

Problem solved.