USB mouse works very slow.

Asked by Rafael Casar on 2011-02-05

I have installed the edubuntu 10.10 version. During the installation (with ACPI=off option), both of my USB mouse and touchpad worked fine. However, now (after installation) only the touchpad works fine, the USB mouse works very slow. I don't know why during the installation the USB mouse worked fine and now not. What can I do? Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-02-07
Last query:
2011-02-07
Last reply:
2011-02-07

What is the make and model of the laptop (sounds like a laptop)

Thanks

Yes, it's a notebook PC. It is a MEDION micromaxx, model MIM2080.

Did you apply the acpi=off setting to the installed OS?

I applied the acpi=off setting BEFORE installation (F6 Option at the begining) because without this option the installation crashes at the begining. But now I don't know if I have to set acpi=off again and how I must do it.

run:

gksudo gedit /etc/default/grub

find this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

Save the new file and close gedit and run:

sudo update-grub

Reboot to test

ACPI is used to manage battery levels and to show you the level of charge left but it's worth exploring just to test. You may have found a bug with ACPI with your model device. You can always reverse the edit to get it back.

After changing to "quiet splash acpi=off" and rebooting, my USB mouse works fine! But now I have a new problem: my wireless network connection fails (before changing the grub file, it worked perfectly). I mean, it doesn't appear the available wireless networks, so I can connect to nothing. Why this option "acpi=off" affect to my wireless network connection?

Because the ACPI controls the power in the whole system, maybe the wireless needs the ACPI to work.

Do you have the latest BIOS for the system, the newer BIOS may solve ACPI issues in the USB and would mean you don't need the boot optoion

OK, I will try to update the BIOS. Thank you very much.