after upgrading to 12.04 mouse wheel stops working

Asked by Michal Suchanek on 2012-08-30

I run ubuntu like this : kvm -m 2048 -usb -usbdevice tablet -vga vmware -hda ubuntu.img

In 11.10 mouse worked flawlessly (except for the minor annoyance that in some windows the mouse cursor was invisible).

In 12.04 mouse scrolling does not work.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-evdev Edit question
Assignee:
No assignee Edit question
Solved by:
Michal Suchanek
Solved:
2012-09-03
Last query:
2012-09-03
Last reply:
2012-08-30

What is the make and model of the system?
Is it a USB mouse?
Is it a laptop or desktop?

Details please.....

Michal Suchanek (hramrach) said : #2

It is a kvm virtual machine as mentioned in the very first line of the question.

Sadly, apport-collect does not seem to work with questions.

It has the USB tablet/PS2 mouse/vmmouse device combo which is found in every kvm machine (the USB tablet is optional, the PS2 mouse can be disabled with a patch).

Are there amy bugs reported?

Michal Suchanek (hramrach) said : #4

Of the numerous scrolling bugs Bug #1039523 might be related I guess.

Sadly it did not show up when I was reporting this. Perhaps because apport insisted on making a question and not a bug report.

Michal Suchanek (hramrach) said : #5

applying the patches in that bug fixes the issue.