erratic behavior of touchscreen (xev reports inconsistent events)

Asked by Krastanov on 2012-06-21

On the wetab tablet with 12.04

The touchscreen becomes unusable after some use. There is no obvious trigger. The pointer moves, but no clicks are detected.

xev reports 'notify' and 'release' events but no 'press' events
xev status is locked into 0x100
xinput test-xi2 reports raw press and release events

Adding a usb mouse works, however the status rests 0x100 and the touchscreen rests unusable

These may be related:
http://askubuntu.com/questions/153043/inconsistent-mouse-x-events-for-acer-t231h-multitouch-monitor
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/1015183

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu xserver-xorg-input-evdev Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-21
Last reply:
2012-06-21

No mention of make or model of the system? Why is this? Can you tell us please...

Krastanov (krastanov-stefan) said : #2

It is the WeTab tablet as I have written above. Here are more details:
http://en.wikipedia.org/wiki/WeTab

Basically and Intel Atom computer with a touchscreen.

And concerning the touchscreen xinput list says this
 eGalax Inc. USB TouchController

Are there any bugs reported?

Krastanov (krastanov-stefan) said : #4

In the related bugs field and in the description I have already mentioned a bug that may be related.

However, a bug about this exact problem is not yet reported. The bug reporting page on launchpad encouraged me to check first here and only then to file a bug.

Can you help with this problem?

Provide an answer of your own, or ask Krastanov for more information if necessary.

To post a message you must log in.