ASUS M5A97 Pro onboard USB 2.0 and NIC not working under Ubuntu 11.xx

Asked by Torben Leutenantsmeyer on 2011-11-09

I have much trouble with Ubuntu 11.10. I have a quite new system with an ASUS M5A97, and neither NIC nor USB 2.0 are working. The first problem could be solved by using a vendor driver, but the latter still exists. Mouse (Logitech MX900) and keyboard (Logitech Illuminated KB) are not recognized. I have older devices with I have kept for emergencies plugged to USB 3.0 or PS/2 which are then recognized and working. But this particular mouse and keyboard are not working even when plugged to USB 3.0. Grub 2 and Windows 7 have no such problems.

This chipset problem almost only exists in Ubuntu, live CDs based on other distrubutions (System Rescue CD, Parted Magic) work just fine. There is a guy reporting to have the same problem with Archlinux, but it hasn't been solved to date:

https://bbs.archlinux.org/viewtopic.php?id=125735

Is there any chance that this issue (the board is out for sale since january) will be solved one day? Has anyone an idea what to do to get the onboard USB running? Apart from switching to another distribution, of course.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-evdev Edit question
Assignee:
No assignee Edit question
Solved by:
Torben Leutenantsmeyer
Solved:
2011-11-10
Last query:
2011-11-10
Last reply:
2011-11-10

Do you have the latest BIOS?

Yes, I had board firmware and driver updates right after Windows 7 installation.

I just checked back and found a new beta rom on ASUS' homepage which seems to solve the problem.
The keyboard is working fine, and I still got trouble with the mouse, but this seems to be a bluetooth issue which can be solved with HIDPoint.

Thanks so far.

BTW, the onboard NIC is Realtek RTL8111E which is already being discussed on.

karl anliot (kanliot) said : #5

it is wrong to tell people the new ROM fixes it. It fixes nothing.
Apparently the only way to fix it, is to install the proprietary drvier from realtek. google it for instructions.
I've heard reports that this is fixed in 12.04, but I doubt it.