Keyboard stops working

Asked by ComoxLinux on 2011-07-12

I'm using a Dell Mini 910 netbook and my keyboard ceases to work a short time after booting. Mouse is fine. It came with Hardy Heron and I've done all the updates since I got it (about three years ago). I assume it was one of these, since this started after one of those - not sure which one. Been hoping that one of them would fix it, but so far none has.

Been this way for some time and it means I don't use it much. Even making changes that require a password is a problem. Can anyone suggest a solution? Should I try installing different version of Ubuntu?

My netbook has a virtual 16 gig hd, and I thought it might be overloaded. So I removed some software - games and such - I didn't use, but nothing has worked.

I'm not very proficient in Linux, so I can't do the technical fixes I've seen for similar problems, unless explained in detail.

Any help appreciated.

Angela

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-evdev Edit question
Assignee:
No assignee Edit question
Solved by:
ComoxLinux
Solved:
2011-07-16
Last query:
2011-07-16
Last reply:
2011-07-15
mycae (mycae) said : #1

Do you have an external USB keyboard that you can try plugging in when the keyboard locks up? If so, does this allow you to work with the computer with the external keyboard?

If so, it may be that either there is a physical problem with your built-in keyboard or it may be possible to look at the system logs to see if there is an clear software problem.

Also, please let us know what version of Ubuntu you are running right not (you might or might not have upgraded from Hardy to newer releases, and there are a number of releases since Hardy). You can find this out by opening a Terminal window and running the command:

lsb_release -a

ComoxLinux (valleyincline) said : #3

Thanks for the quick replies.

My version of Hardy Heron is 8.04.2 - and "no LSB modules are available", according to the message that came up in terminal - whatever that means.

Right now the keyboard is working in Open Office Writer, online, and everywhere else I try it, including password protected functions - and for the longest time since this problem began. I did notice one day recently that it worked for quite some time before ceasing up. Often I can't even type a URL. I have a full-szed USB keyboard handy, so will try that if the problem re-occurs and report back.

It's a mystery to me why this problem is suddenly not happening. You guys are GOOD!! Remote fix! Only kidding ...

Funny thing is that the Update Manager says the package info was last updated 783 days ago. I allowed a load of updates a few days ago. Is this possible? Maybe the fix came through after all.

Angela

Only the server version of Ubuntu 8.04 LTS Hardy Heron (and only the packages in the main component, minus any packages that create or use a graphical user interface) is still supported. The desktop version ceased being supported a while ago. That means you won't receive security and other updates for many parts of your system (only for the parts that are also present in the server version), and also that you won't be likely to get much help on this forum or from similar resources like Ubuntu Forums, AskUbuntu.com, or the IRC channel.

For these reasons (primarily the lack of security updates as vulnerabilities are discovered and potentially exploited), you should upgrade to Ubuntu 10.04 LTS Lucid Lynx. Lucid will be supported for quite a while, but if you want to use an even later version (which would not be an LTS version, and thus might potentially be less stable), you could upgrade from Lucid to 10.10 Maverick. And then, if you wanted, you could upgrade from Maverick to 11.04 Natty. (Lucid, Maverick, and Natty are all currently supported.)

You can upgrade from Hardy (which is the release you're currently running) to Lucid using the Update Manager. (If you decide you want to upgrade to an even newer release than Lucid, then after upgrading to Lucid and booting into your Lucid system, you can enter the Update Manager and upgrade to the next release, and so forth.)

Upgrading to Lucid might well solve your problem. If you upgrade to Lucid and your problem persists, then please post a reply to reopen this question and obtain more assistance. (If you upgrade to Lucid and the problem does not persist, then you can mark this question as Solved.)

"Funny thing is that the Update Manager says the package info was last updated 783 days ago. I allowed a load of updates a few days ago. Is this possible?"

I'm not sure if the Update Manager is reporting how long it has been your local package information was updated, or how long it has been since your local package information was updated **by the Update Manager**. (This is something I don't personally know, not something nobody knows.) If the latter interpretation applies, then it's possible something other than the Update Manager has been updating your local package cache (providing information that the Update Manager may have used to download and apply your recent updates). One way this might be able to happen could be if you have enabled automatically checking for and/or downloading updates. If you really want to investigate this, then you could look at the logs in /var/log/apt and at /var/log/dpkg.log.

"Maybe the fix came through after all."

That is possible, specifically if the fix was in the package called linux-image-generic (or linux-image-generic-pae). This problem could also be localized in some part of the X Window System, but since that's part of Ubuntu's graphical user interface, it is not likely to have bugs fixed recently in Hardy.

If the bug is not fixed, there is a significant chance that it may be fixed when you upgrade to Ubuntu 10.04 LTS Lucid. If the bug is fixed, then most likely it is also fixed (or was never present) in Ubuntu 10.04 LTS Lucid (though it is imaginably possible that it was just fixed in Hardy, but is present in Lucid and not fixed--in any case, you should still upgrade to Lucid because of the security risks that you have been incurring and would continue to incur by continuing to use Ubuntu 8.04 LTS Hardy).

ComoxLinux (valleyincline) said : #5

Thanks for the advice, but there's a problem. My Update Manager says it can't download all repository indexes (i.e. there are a lot of "failed to fetch" lines) and I get no option to upgrade to a newer version. Is there another way to do this? Can the newer version be installed via a USB flash drive, for instance? Since this is a Dell machine, is there perhaps something preventing an upgrade to the Ubuntu version it came with?

The keyboard problem is back again, so no idea what happened yesterday to make it suddenly work. It's annoying because I have to keep rebooting if I need to type anything more than a word or two.

Angela

"Can the newer version be installed via a USB flash drive, for instance?"

You cannot do this with the desktop CD or DVD (until Ubuntu 11.04 Natty Narwhal), but you could use the alternate CD for this purpose, provided that you followed the specific procedure for doing so (see below). However, I do not recommend that you do this. If your system is broken to such a degree that other upgrade methods don't work, then upgrading using the alternate CD might result in an Ubuntu 10.04 LTS system that is not actually in a usable state.

"Since this is a Dell machine, is there perhaps something preventing an upgrade to the Ubuntu version it came with?"

Your system's package manager might be configured to use a Dell-specific update server which provides packages for Hardy but not for other releases such as Lucid. You can check if this is the case by going into the Update Manager, clicking Settings... on the lower-left corner to open up the Software Sources window, click the Ubuntu Software tab, and see which server is selected in the drop-down menu to the right of the text "Download from:". If this is a Dell-specific server, you can change it to "Server for United States" or wherever you are (there are a number of regional servers) and see if that fixes the problem.

"The keyboard problem is back again, so no idea what happened yesterday to make it suddenly work."

What happens when you attach the USB keyboard? Does that work?

A detailed explanation of how to update is at https://help.ubuntu.com/community/LucidUpgrades#Upgrade%20from%208.04%20LTS%20to%2010.04%20LTS. First try the procedure titled "Network Upgrade for Ubuntu Desktops (Recommended)" (don't use the Kubuntu procedure, which comes right after that). If that fails, you can try "Network Upgrade for Ubuntu Servers (Recommended)", but please note that it would be difficult to either continue or properly cancel an upgrade if your keyboard stops working in the middle. If those fail (or if you don't want to attempt to perform the second procedure for fear of more severely worsening the existing problem or rendering your Ubuntu system unbootable), it's probably best to repair whatever is wrong with your package manager, rather than attempt to upgrade using an alternate CD, especially if you do not already happen to have an alternate CD on hand.

To repair whatever is wrong with your package manager, perform the steps at https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure. If that does not succeed at making it possible to upgrade from 8.04 LTS to 10.04 LTS, then it may still reveal useful information, so in that case, please select all the text from the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it here.

ComoxLinux (valleyincline) said : #7

Thanks once again, Eliah.

I should have mentioned that I tried the USB keyboard and it didn't work either.
This is a older netbook, so it doesn't have a CD/DVD drive and only a 16 gig virtual HD. It does have a dual core, so it's very fast.

I'll check my system package manager setting as you suggest and try and download the new version. I'll also read up on the stuff you recommend.

Thanks for the tips. Will let you know what happens.

While it doesn't necessarily make a difference in this case because I am recommending against using the alternate CD, the alternate CD .iso image can be written to a USB flash drive, and all the same tasks can be performed by booting from that flash drive as can be performed by booting from a burned CD. (Similarly, the desktop CD .iso image and the DVD .iso image can be written to USB flash drives.)

ComoxLinux (valleyincline) said : #9

Ok - here's the latest. I couldn't update through the version of Ubuntu I'm using - Hardy Heron. There is no option to do so. There's also no option to create a start up drive. So I downloaded the iso for the version you suggested - 10.04 lts - to my Win 7 desktop. Then I downloaded the universal installer and followed the instructions to create a bootable USB drive from the iso. I plugged this into my netbook and rebooted. Nothing. I tried to initiate autorun manually. I get the option to RUN but nothing happens when I choose it. Is the problem that this iso USB installer extraction was created in Win 7? Should I redo the process and try and do it on my netbook? Should I use the server version of 10.04 which is for a 64 bit computer, which is what my netbook is? Can I download the iso to my desktop, then copy it to my netbook along with the universal installer? Want to get this right.

If you're going to install from scratch by booting the machine from a USB flash drive with the Ubuntu 10.04 LTS installer, then you should make sure to first offload all your documents and important files (e.g., ebooks, music, videos), as this process will typically erase them from your computer.

You should be able to write the .iso image on either Windows 7 or your existing Ubuntu system, without problems. Assuming that the .iso image has the correct MD5SUM (you should check this if you haven't; see https://help.ubuntu.com/community/HowToMD5SUM), and assuming you are writing it to the USB flash drive correctly (click "Show me how" in step 2 at http://www.ubuntu.com/download/ubuntu/download), it's likely that the problem is with getting your netbook to *boot* from a USB flash drive.

Have you ever gotten your netbook to boot from a USB flash drive before?

If not (especially if you had never tried before), then it's likely that you simply need to figure out how to tell your netbook to boot from an external USB device. There will probably be a key to hold down while you start up the netbook. It will probably tell you on the screen, briefly, what key that is, as you start it up. Whether or not there is such a key, there will be a key to hold down to enter the BIOS setup, and you can change the boot order in the BIOS setup to put external USB devices ahead of the internal hard drive.

ComoxLinux (valleyincline) said : #11

Thanks again.

I did very little work on the netbook because of the keyboard problem so there's nothing on it to save.

I have have now managed to boot from the USB by changing the boot option in the BIOS setup. 10.04 LTS has installed. I should have thought of doing that a long time ago. DUH!

Now I'm trying to get the netbook to find my wireless network - just a matter of time, I hope.