is library (motif) installed? (libXm.so.3 or libXm.so.4)

Asked by David on 2012-02-20

Thanks to some well directed help here, I have successfully installed eloTouch touchscreen drivers for 10.04, and gotten a command line utility to calibrate the touchscreen

However, I wanted to see if I could get the X GUI utility to work (there are libXm.so.3 and .4 versions available)

I was told to install the apt-file package, and ensure .3 or .4 motif libraries were available

1) I installed the apt-file package
2) performed the update
3) searched with apt-file search libXm.so.3 or 4 (see output below)

USERNAME@HOSTNAME:~$ apt-file search libXm.so.3
libmotif3: /usr/lib/libXm.so.3
libmotif3: /usr/lib/libXm.so.3.0.2
USERNAME@HOSTNAME:~$ apt-file search libXm.so.4
USERNAME@HOSTNAME:~$

so it appears .3 is the library installed (do I need to do anything else to ensure correct "install" of libXm.so.3 or .4?)

I ran another apt-file update just in case

As you may see below, I believe I am
a) in the correct directory (see ls -l command output)
b)I have tried to run the ./cpl command, as well as
c) try to run the ./cpl_motif4 command,
both to no avail

(the cplcmd file is a command line version, which works)

I get the following errors (blank lines inserted for easier reading):

USERNAME@HOSTNAME:/etc/opt/elo-usb$ ls -l
total 308
-rwxrwxrwx 1 root root 203 2011-02-17 18:34 99-elotouch.rules
-rwxrwxrwx 1 root root 77833 2011-02-17 18:34 cpl
-rwxrwxrwx 1 root root 17684 2011-02-17 18:34 cplcmd
-rwxrwxrwx 1 root root 81929 2011-02-17 18:34 cpl_motif4
-rwxrwxrwx 1 root root 442 2011-02-17 18:34 eloCreateFifo.sh
-r--r--r-- 1 root root 7148 2011-02-17 18:34 Elo-Linux-USB-Driver_List-of-New-Features.txt
-rwxrwxrwx 1 root root 228 2011-02-17 18:34 elorc
-rwxrwxrwx 1 root root 35855 2011-02-17 18:34 elousbd
-rw-r--r-- 1 root root 117 2012-02-19 22:55 EloUsbErrorLog.txt
-rwxrwxrwx 1 root root 28881 2011-02-17 18:34 elova
-rwxrwxrwx 1 root root 253 2011-02-17 18:34 loadEloTouchUSB.sh
-r--r--r-- 1 root root 16986 2011-02-17 18:34 readme.txt
-rwxrwxrwx 1 root root 2230 2011-02-17 18:34 setXAuthentication.sh
-rwxr-xr-x 1 root root 460 2012-02-19 00:05 USBConfigData

USERNAME@HOSTNAME:/etc/opt/elo-usb$ ./cpl
./cpl: error while loading shared libraries: libXm.so.3: cannot open shared object file: No such file or directory

USERNAME@HOSTNAME:/etc/opt/elo-usb$ ./cpl_motif4
./cpl_motif4: error while loading shared libraries: libXm.so.4: cannot open shared object file: No such file or directory

I *think* the libXm.so.3 library IS installed...

where am I going wrong, folks?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-input-elographics Edit question
Assignee:
No assignee Edit question
Solved by:
David
Solved:
2012-02-21
Last query:
2012-02-21
Last reply:
2012-02-21

http://packages.ubuntu.com/search?searchon=contents&keywords=libXm.so.4&mode=exactfilename&suite=oneiric&arch=any

Seemsto be in libmotif4 in Oneiric, but doesn't appear to be in Lucid. I suggest you install Oneiric and you'll be ok

Ubfan (ubfan1) said : #2

try running ldd on cpl and see where it thinks the library should be. If it's in some ...X11... place, just add a link there pointing to your installed library.

David (dfkwild) said : #3

For this specific computer, I am running a specific package that is packaged/bundled with Lucid (LinuxCNC - formerly EMC)

On the LinuxCNC site, they talk about it not being able to run on anything except their selected distrobutions (10.04LTS is the latest version for them)

I am not yet ready to tackle getting their distro running on Oneiric - I'm not versed well enough with Ubuntu yet

running ldd against cpl and cpl_motif4 gives the following:

USERNAME@HOSTNAME:~/elo-usb$ ldd cpl
 linux-gate.so.1 => (0x00b2a000)
 libX11.so.6 => /usr/lib/libX11.so.6 (0x0055e000)
 libXm.so.3 => not found
[about ten other dependencies that looked ok]

and

USERNAME@HOSTNAME:~/elo-usb$ ldd cpl_motif4
 linux-gate.so.1 => (0x003db000)
 libX11.so.6 => /usr/lib/libX11.so.6 (0x0088f000)
 libXm.so.4 => not found
[about ten other dependencies that looked ok]

Can I just download the lib4motif package, and copy that specific shared library (libXm.so.4into the /usr/lib directory?

David (dfkwild) said : #4

ok you guys rok

I went searching for libXm.so.3 and .4 in packages for 10.04 in the packages search help on the ubuntu site - the only one was the libmotif4 that andrewparsnip found...

I then went to Synaptics package manager, and found that Lucid has a motif3 package

installed it and the application works!

thanks again folks
David