install touchscreen drivers

Asked by David

essentially I think my issue is I'm trying copy files to "root" owned directory

I just loaded 10.04 LTS version, and am getting it setup to use with a touchscreen monitor, that has a controller built by elotouch touchscreens... in order to set options and calibrate touchscreen, I need to load a generic linux driver

located here:

with a readme for what looks like a simple setup)

I needed to copy files to new directiory: /etc/opt/elo-usb

the graphical interface had paste greyed out, and the permissions were for root access only, and also greyed out, so I did some poking and tried sudo and sudo -i

it didn't like it:

-rwxr-xr-x 1 mpadmin mpadmin 203 2011-02-17 18:34 99-elotouch.rules
-rwxr-xr-x 1 mpadmin mpadmin 77833 2011-02-17 18:34 cpl
-rwxr-xr-x 1 mpadmin mpadmin 17684 2011-02-17 18:34 cplcmd
-rwxr-xr-x 1 mpadmin mpadmin 81929 2011-02-17 18:34 cpl_motif4
-rwxr-xr-x 1 mpadmin mpadmin 442 2011-02-17 18:34
-r--r--r-- 1 mpadmin mpadmin 7148 2011-02-17 18:34 Elo-Linux-USB-Driver_List-of-New-Features.txt
-rwxr-xr-x 1 mpadmin mpadmin 228 2011-02-17 18:34 elorc
-rwxr-xr-x 1 mpadmin mpadmin 35855 2011-02-17 18:34 elousbd
-rwxr-xr-x 1 mpadmin mpadmin 28881 2011-02-17 18:34 elova
-rwxr-xr-x 1 mpadmin mpadmin 253 2011-02-17 18:34
-r--r--r-- 1 mpadmin mpadmin 16986 2011-02-17 18:34 readme.txt
-rwxr-xr-x 1 mpadmin mpadmin 2230 2011-02-17 18:34
mpadmin:~/elo-usb$ sudo cp -r * /etc/opt/elo-usb
*** forbidden path -> "/etc/opt/elo-usb"
*** You have 0 joker(s) left, before getting kicked out.
This incident has been reported.
mpadmin:~/elo-usb$ sudo -i cp -r * /etc/opt/elo-usb
*** forbidden path -> "/etc/opt/elo-usb"
- Kicked out -

Any suggestions?

Question information

English Edit question
Ubuntu xserver-xorg-input-elographics Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :


gksudo nautilus

And you can copy files wherever you want...

Revision history for this message
David (dfkwild) said :
#2 unix days were pre-2k/dot bomb era, so it's slowly coming back

thanks very much!

Revision history for this message
David (dfkwild) said :

Thanks actionparsnip, that solved my question.